Huge font size sometimes crashes [@ gfxWindowsTextRun::MeasureOrDrawFast]

RESOLVED DUPLICATE of bug 333861

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 333861
12 years ago
7 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({crash, testcase, topcrash})

Trunk
x86
Windows Server 2003
crash, testcase, topcrash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a1) Gecko/20060319 Firefox/1.6a1

When loaded as a local file, the testcase usually crashes Firefox within 3 seconds.  If it doesn't crash within 10 seconds, restart Firefox and try again.
(Reporter)

Updated

12 years ago
Flags: blocking1.9a1?
Summary: Huge font size sometimes crashes [@ gfxWindowsTextRun::MeasureOrDrawFast] → Huge font size sometimes crashes [@ gfxWindowsTextRun::MeasureOrDrawFast]
(Reporter)

Comment 1

12 years ago
Created attachment 215752 [details]
testcase

Testcase based on iexploder test 167080.
(Reporter)

Comment 2

12 years ago
TB16631838W only shows 5 lines of stack:

gfxWindowsTextRun::MeasureOrDrawFast   
gfxWindowsTextRun::MeasureString   
nsThebesFontMetrics::GetWidth   
nsThebesRenderingContext::GetWidth   
nsThebesRenderingContext::GetTextDimensions  

Comment 3

12 years ago
I have seen issues with large fonts in bug 27650

Comment 4

12 years ago
now fixed -- clamping to 5000 for all fonts for now.

*** This bug has been marked as a duplicate of 333861 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Keywords: topcrash

Comment 5

12 years ago
crashed on weekend, same stack as comment 2.
TB19782557  (ignore my comment about "startup")
trunk build 2006050805

happened when PC was unattended and some application messed up video display causing large (2x or 3x font).
(Assignee)

Updated

7 years ago
Crash Signature: [@ gfxWindowsTextRun::MeasureOrDrawFast]
You need to log in before you can comment on or make changes to this bug.