Closed Bug 331211 Opened 16 years ago Closed 13 years ago

Misleading cursor (hourglass/Busy) displays during IMAP or NNTP processes

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird 3.0b2

People

(Reporter: autodmc, Assigned: philor)

References

Details

(Keywords: polish)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: http://download.mozilla.org/?product=thunderbird-1.5&os=win&lang=en-US

During IMAP operations in Thunderbird (Opening folder, downloading headers, etc) on Windows, the mouse cursor changes to an hourglass while the operation takes place.

Unfortunatly, to windows users, and hourglass is almost as bad as a Blue Screen of Death;  it's one of the first symptoms of a possible crash.

A better solution would be to throw up the Pointer+Hourglass  (Working in Background) pointer.

The hourglass/busy cursor implies that a program is busy processing and cannot accept input;  the Pointer+Hourglass/Working in Background pointer implies that the program is processing in the background, but can still accept input.

The second case describes the actual operation of Thunderbird;  while an operation is taking place, the user can preempt the operation by simply "clicking on another operation," such as choosing a different folder, etc.

And you don't end up with the assumption of the "Spinning Hourglass" crash.

Reproducible: Always

Steps to Reproduce:
1. Log into an IMAP account.
2. Start a operation (such as clicking on your "Inbox")

Actual Results:  
The UI throws up a Hourglass/Wait cursor, the status bar displays the current operation (Opening folder...), and the "Undefined Operation Time" Progress Bar appears for the length of the operation.

Expected Results:  
The UI should throw up a Pointer+Hourglass/Working in Background cursor, the status bar displays the current operation (Opening folder...), and the "Undefined Operation Time" Progress Bar appears for the length of the operation.
Version: unspecified → 1.5
QA Contact: front-end
Duplicate of this bug: 390061
and still reproducible on latest trunk 2008040204. As I said on my dupe bug it's very anoying if you are working on slow connection. Even if hourglass cursor appears you sill can use it to make selections.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: mscott → nobody
Version: 1.5 → 2.0
I believe this depends on 435153 which fixed, will test on slow connection to see if it works for now.
Depends on: 435153
Bug 435153 is not affect behavior of current trunk. As described per original bug submitter busy cursor are kind confusing, regular John Doe will belive it can do anything during selecting folders in IMAP for example but it can regardless of busy cursor. Can we change this behavior to reflect real stat of TB - just background process. And this apply to NNTP too.
Not really big code change need (correct me if I'm wrong) requesting for blocking TB3 for this more user-friendly bug.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090109 Shredder/3.0b2pre
Flags: blocking-thunderbird3?
Summary: Misleading cursor (hourglass/Busy) displays during IMAP processes → Misleading cursor (hourglass/Busy) displays during IMAP or NNTP processes
Version: 2.0 → Trunk
mistype
John Doe will believe it *can't* do anything during selecting folders in IMAP for example but it can
Yes, it's not much code, but the criterion for blocking is "if this is the only bug left, do I think that the release should be held, keeping Tb3 away from users, until it is fixed?" For something like this, where you don't think that, wanted? and the polish keyword are more appropriate.
Severity: trivial → normal
No longer depends on: 435153
Flags: wanted-thunderbird3+
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3-
Keywords: polish
OS: Windows XP → All
Hardware: x86 → All
Attached patch Fix v.1Splinter Review
But at least we're well ahead of SeaMonkey, who took six years to land their patch in bug 178767 :)
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #356909 - Flags: review?(mkmelin+mozilla)
Duplicate of this bug: 466158
Attachment #356909 - Flags: review?(mkmelin+mozilla) → review+
Comment on attachment 356909 [details] [diff] [review]
Fix v.1

Nice! r=mkmelin
http://hg.mozilla.org/comm-central/rev/25d5967e1ce6

(Surprising how much psychological difference this made, while I was running with the patch in my tree, despite knowing it made no practical difference.)
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b2
Thanks Phil, also would like to say it really major psychological difference - feels more comfortable and fast ;)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.