Save information I enter in forms... causes Firefox to hang when a list is shown for selection

RESOLVED DUPLICATE of bug 318283

Status

()

Firefox
Preferences
--
critical
RESOLVED DUPLICATE of bug 318283
12 years ago
12 years ago

People

(Reporter: Ron Taylor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

If the option to "Save information I enter in forms and the Search Bar" is checked under Preferences>Privacy then whenever a list of possible entries to auto fill a field is presented, the Firefox browser freezes and OS X shows the spinning color wheel forever.  If that option is un-checked, the problem is resolved.  This does not seem to happen on other platforms.  It may be limited to OS 10.2.8 but I can check it on 10.3.9 and 10.4.5 to be sure.

Reproducible: Always

Steps to Reproduce:
1.  Check Preferences>Privacy>Save information I enter in forms and the Search Bar
2.  Open a screen that requires something to be entered like an email name
3.  Type in a few different names to the form
4.  Now type in one of the names that was previously entered
5.  Firefox will show the list of names that may match your entry and then hang

Actual Results:  
OS X puts up the spinning color wheel and never returns.  Only way out is to force quit Firefox or shutdown the computer.

Expected Results:  
It should have allowed either the user to continue typing in whatever he wanted into the field or to select one of the entries in the saved list.

This seems to have started to happen with Firefox 1.5 or 1.5.0.1 because no one reported this trouble with prior versions.  This has happened on eMacs and iBooks.

Comment 1

12 years ago
(In reply to comment #0)
> This does not seem to happen on other platforms.  It may be limited
> to OS 10.2.8 but I can check it on 10.3.9 and 10.4.5 to be sure.

Duplicate of Core bug 318283 or maybe Core bug 298502 (see bug 298502 comment 94)?
This will be fixed in Firefox 1.5.0.2.

*** This bug has been marked as a duplicate of 318283 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.