Closed Bug 331222 Opened 19 years ago Closed 19 years ago

context menu search does not observe browser.tabs.loadInBackground setting; always opens in foreground

Categories

(Firefox :: Search, defect, P2)

2.0 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 2 beta1

People

(Reporter: mmortal03, Assigned: Gavin)

References

Details

(Keywords: fixed1.8.1)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060320 Firefox/1.6a1 ID:2006032009

The new Search bar code, which includes a new "Search [Selected Engine] For" context menu option, doesn't observe browser.tabs.loadInBackground setting anymore, and always opens in foreground.

Reproducible: Always

Steps to Reproduce:
Please note that the listed User-Agent build is not the build containing the bug.

Please file this bug against gavin.sharp@gmail.com.
You're talking specifically about context menu search, right?
Assignee: nobody → gavin.sharp
Summary: new Search bar code does not observe browser.tabs.loadInBackground setting; always opens in foreground → context menu search does not observe browser.tabs.loadInBackground setting; always opens in foreground
So, hrm, we always opened context search in the background, it was explicitly called like that since pre 0.7.  We've never observed a pref for the searchbar or for context search, though we should think about that (and which pref to observe)

At the minimum, we should restore the 1.5 behaviour for alt-enter in the searchbar and context search.
Status: UNCONFIRMED → ASSIGNED
Depends on: 324604
Ever confirmed: true
Flags: blocking-firefox2+
Target Milestone: --- → Firefox 2 beta1
Since Gavin was just fixing it, not implementing it, in bug 276318, I think we have actually observed the pref for context search.
Ah, yeah, my patch did regress context menu search obeying the pref, patch for that in a sec. I'm not sure whether this behavior needs tweaking any further - I'll have to think about that.
Priority: -- → P2
Attachment #215817 - Flags: review?(mconnor)
Attachment #215817 - Flags: approval-branch-1.8.1?(mconnor)
Attachment #215817 - Flags: review?(mconnor)
Attachment #215817 - Flags: review+
Attachment #215817 - Flags: approval-branch-1.8.1?(mconnor)
Attachment #215817 - Flags: approval-branch-1.8.1+
mozilla/browser/base/content/browser.js 	1.594
mozilla/browser/base/content/browser.js 	1.479.2.98
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 2.0 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060327 Firefox/1.6a1 ID:2006032721

seems to be fixed.
*** Bug 332805 has been marked as a duplicate of this bug. ***
Bug 331522 regressed this. I'll fix that once bug 334776 is fixed.
Depends on: 334776
This bug as summarized is fixed now. mconnor: was there something else you wanted to deal with in this bug? I'm not sure what the dependency on bug 324604 is for.
THis is probably fixed now, but I wanted it linked so I was able to follow up in the consistency review.
Ok, fixed+fixed1.8.1 then.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: