PC starts to be slower when downloading something, specially at high download rates

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: raulvior.bcn, Unassigned)

Tracking

1.8.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/05, URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

Always I start a download, my computer starts to "microfreeze", so it's very unconfortable (specially with large downloads...).

Reproducible: Always

Steps to Reproduce:
1. Go to the web http://www.epx.epita.fr/misc/isos/kororaa-xgl-demo-livecd-0.1.iso
2. See what happens.

Actual Results:  
Computer started to "microfreeze" until the download finished.

Expected Results:  
Behave normally, without freezing my computer.

On the system monitor (I use Ubuntu Breezy), it shows that firefox-bin is using the 30% of my CPU, getting sometimes 100%, and using a total of ~115MB of memory.
My CPU is an Athlon Thunderbird 1Ghz, FSB 266Mhz, with 512MB Kingston DDR RAM.
After finishing the download, the CPU use returns to 0%.
(Reporter)

Comment 1

13 years ago
Created attachment 215825 [details]
Image showing the system monitor and the download in progress
Can you reproduce after trying the standard diagnostic? (http://kb.mozillazine.org/Standard_diagnostic_(Firefox))
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Can you reproduce after trying the standard diagnostic?
> (http://kb.mozillazine.org/Standard_diagnostic_(Firefox))
> 

Yes, I tried the Standard diagnostic, and it stills goes "choppy". I have to say I don't have any extension, and I was using the default options (except I had a "new tab button" on the toolbar, and links opening new windows where configured to open new tabs).
What are the specs of your internet connection?
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> What are the specs of your internet connection?
> 
I have an ADSL2+, wich speed rate is now (it changes during the day between 10.5Mbps and 13Mbps of download, the upload is more or less the same, between 840Kbps and 900Kbps):

Line Rate - Upstream (Kbps):  	888
Line Rate - Downstream (Kbps): 	11966
Have you tried deleting downloads.rdf from your profile folder?
I think this might be a dupe of, or related to bug #91232.

Comment 7

12 years ago
I've seen the same behaviour. It is linked to the downloads list (CRTL-J) having LOTS of entries. Cleaning up the list will eliminate the performance issues.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/05
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 9

12 years ago
(In reply to comment #8)
> Reporter, do you still see this problem with the latest Firefox 2? If not, can
> you please close this bug as WORKSFORME. Thanks!
> 
Nope, I don't see this problem anymore, thanks :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.