If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Print preview size does not update after changing scale

RESOLVED WORKSFORME

Status

()

Core
Print Preview
RESOLVED WORKSFORME
12 years ago
4 years ago

People

(Reporter: John T, Unassigned)

Tracking

Trunk
x86
All
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.13) Gecko/20060321
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.13) Gecko/20060321

The sample page appears at a large scale though the scale indicator said 30% when the window was first opened. Scale changes produced no significant size changes in the fonts from 30% to about 125% though the font appeared a bit larger at 175% scale. Scaling the page down below 100% does not result in the page size and page count being reduced, though scaling it up produces an increase in the indicated number of pages. There's no noticeable change in font size or number of printed pages in the range of 30% to 125%.




Reproducible: Always

Steps to Reproduce:
1. Navigate to the indicated web page.
2. Click on the file/print preview menu entry
3. Observe the print preview window.
4. Try various scale settings.

Actual Results:  
The scale setting changes do not produce the expected changes in the size of the fonts and displayed pages, or expected changes in the number of printed pages.

Expected Results:  
The scale changes should produce changes in the size of the page display and changes in the number of printed pages indicated.

Comment 1

12 years ago
Related to/duplicate of Core bug 205001?

Comment 2

12 years ago
Changing summary to better reflect description (since word scale was used 6 times in it).

Changing Product to Core 
since I get the actual results with Firefox 1.5.0.1. 

This must be a duplicate of another bug; there are many bugs related to scaling in print preview, and over 500 bugs regarding print preview.

Bug 205001 is about absolute length unit while the page at
http://www.mozilla.org/developer/
uses these declarations (relative length unit):

    body, td, th, input { /* redundant rules for bad browsers  */
            font-family: verdana, sans-serif;
            font-size: x-small;
            voice-family: "\"}\"";
            voice-family: inherit;
            font-size: small;
    }

	h1 { font-size: 160%; font-weight: normal; }
	h2 { font-size: 150%; font-weight: normal; }
	h3 { font-size: 120%; }
	h4 { font-size: 100%; }
	h5 { font-size: 90%; }
	h6 { font-size: 90%; border: 0; }
Component: General → Print Preview
Product: Mozilla Application Suite → Core
Summary: Print preview size isn't adjustable → Print preview size does not update after changing scale
Whiteboard: DUPEME
Version: unspecified → Trunk

Comment 3

12 years ago
Oops.. I got that wrong: the CSS declarations come from
http://www.mozilla.org/css/print.css
and they are relative for headers but not for body element.
(Reporter)

Comment 4

12 years ago
Using Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.13) Gecko/20060328, Print Preview scales fine for email messages and for some web pages. This is the only problem web page I'm seeing: http://www.mozilla.org/releases/mozilla1.7.13 It doesn't scale up or down properly in the range 125%-40%.

However, I noticed that in viewing at least one page http://www.linuxcentral.com/_v3/, the print preview page seems to be contacting the site of the web page being displayed---is this normal?

Comment 5

11 years ago
This bug appears in XP as well

Comment 6

11 years ago
This bug appears in XP as well
(Reporter)

Comment 7

11 years ago
Is it intentional that Seamonkey 1.5a for Linux doesn't have scale adjustment in its print preview menu? Is the scaling in page setup considered adequate for most users?
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061017 SeaMonkey/1.5a

Updated

11 years ago
Duplicate of this bug: 366134

Comment 9

11 years ago
Basically, Print Preview customization is broken on Windows, Upgrading and confirming.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.9?
OS: Windows 98 → All
Flags: blocking1.9? → blocking1.9+

Comment 10

11 years ago
This should be working now, I think.

Comment 11

11 years ago
When I try the steps to reproduce with Seamonkey 1.5a rv:1.9a3pre build 2007022208 under XP Pro SP2, I get the expected results.

WORKSFORME

Comment 12

11 years ago
I'm resolving this bug as WORKSFORME. If you believe this is an error, please reopen and explain why with details, specifics, explanations, etc.
Also, I'm resetting the severity to normal. There was nothing supporting that this bug was critical. Critical is only for crashes, loss of data, severe memory leak.

Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Severity: critical → normal

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.