pop up blocker notification is intrusive

VERIFIED WONTFIX

Status

--
enhancement
VERIFIED WONTFIX
13 years ago
13 years ago

People

(Reporter: phiw2, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060322 Camino/1.2+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060322 Camino/1.2+

The new pop-up blocker notification is fairly intrusive:
* html document jumps down when the notification pops up.
* the background colour makes it feel a bit agressive
* requires the user to click to dismiss.
* the notification does not feel or look like part of the chrome.

This is a folow up on a discussion in the forums
http://forums.mozillazine.org/viewtopic.php?t=396209

Some suggestions have been floated in the above discussion:
* revert to an icon in the statusbar (that *is* a job for the statusbar: notifying the user about things that happen with the document being loaded/viewed) - probably *WONT*, but I mention it anyway.
* make the notification look more a part of the chrome (toolbars): use of the same background-colour (grey) to emphasis the continuity with the chrome.
* use of an icon in the existing toolbar (cons: clutter, not much visibility).
* positioning the notification floating on top of the html document - no more jumping on load.
* position the notification at the bottom of the window - similar to the FAYT (find as you type) in Firefox.

Several of the above can be combined.
I personally like the idea of positioning it at the bottom of the window, look and feel integrated with the chrome: grey background, similarly sized text. a small icon can be added to give more visibility.

Reproducible: Always
> * the background colour makes it feel a bit agressive

See bug 331331 for that one bit.

I'm almost of the opinion that the way to fix this is to pref it, despite all the evilness that it entails.  

It seems to me that the userbase is fairly strongly divided between the part that finds Firefox-style notification as annoying as the pop-ups the feature is supposed to block and the part (rf. feedback and recently-closed bugs) who never realized that pop-ups were being blocked after turning on the feature.
(In reply to comment #0)
> * html document jumps down when the notification pops up.

Unfortunately, as annoying as that may be, it's part of the entire package. There's not logical way to fix it and keep the new notification bar.

> * the background colour makes it feel a bit agressive

Smokey covered this in comment 1.

> * requires the user to click to dismiss.

Again, this is part of the idea of a notification bar. If you have ideas for new prefs or something similar that would not show the bar in some instances (blacklist or otherwise), please file a bug.

> * the notification does not feel or look like part of the chrome.

This is more subjective, but changing the color will certainly help with that.

> Some suggestions have been floated in the above discussion:
> * revert to an icon in the statusbar (that *is* a job for the statusbar:
> notifying the user about things that happen with the document being
> loaded/viewed) - probably *WONT*, but I mention it anyway.

This is definitely a WONTFIX. The decision has been made to make the blocked popup notification more visible and this is where it went.

> * make the notification look more a part of the chrome (toolbars): use of the
> same background-colour (grey) to emphasis the continuity with the chrome.

Again, covered in the other bug.

> * use of an icon in the existing toolbar (cons: clutter, not much visibility).

Notifications typically don't belong in toolbars. A toolbar button shouldn't be disabled the majority of the time or it's no longer useful. This proposed toolbar icon would also have to be part of the default set, which is even less appealing.

> * positioning the notification floating on top of the html document - no more
> jumping on load.

Not too bad of an idea except then content is hidden by the bar and hiding content (that can't be scrolled to) is a fairly big "no no". I'd WONTFIX this idea as well.

> * position the notification at the bottom of the window - similar to the FAYT
> (find as you type) in Firefox.

I highly doubt this will happen. When the status bar is hidable, this will look awkward and act weird.

Overall, this bug doesn't have any new ideas which I feel are likely to be done. Proposals should be taken in new bugs one by one to improve various aspects of the notification bar or to scrap it altogether in favor of a better (as of yet, unspecified) solution.

I fully recommend WONTFIX for this bug based the above.
Assignee: mikepinkerton → nobody
QA Contact: general

Comment 3

13 years ago
I'm with Smokey, and Pink and I talked about this a bit on IRC. It's ugly, but I'm still of the opinion that the only real solution is to have a pref that switches from the new behaviour to putting the notification in the status bar (where it belongs).

Ship it with the current behaviour, but let people hide the notification if they want. That's the whole point of the status bar, after all, and if people hide notifications and hide the status bar (which is a more WONTFIX-worthy bug, IMO), tough cookies.

cl
As I said: "Proposals should be taken in new bugs one by one to improve various
aspects of the notification bar or to scrap it altogether in favor of a better
(as of yet, unspecified) solution."

This bug should be WONTFIXed based on the ideas in comment 0. If someone wants to file a new bug with new ideas, please feel free (be sure to file as UNCO until Mike voices his opinion). However, this bug pertains to *improving* the popup blocker with the ideas in comment 0, none of which are very good ideas (besides the one covered in another bug, of course). I still recommend WONTFIX.

Comment 5

13 years ago
I agree with Sam.  Bug 333531 now covers preffing the old pop up notification (which seems to be the only idea anybody likes at all), so this bug is basically just a complaint forum.  I say WONTFIX.
If anyone has concrete proposals other than bug 331331 or bug 333531, file them as new bugs per comment 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.