Can only install extensions on 1 profile in XP using Firefox 1.5

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Michael Rodriguez, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

I am on my wife's profile and none of the extensions that I have on my profile can be installed on hers.  The extensions appear in the extension manager but when they dont work at all and if I try to click on the options button for an extension it freezes up Firefox.

Reproducible: Always

Steps to Reproduce:
1.download an extension
2.restart firefox after install
3.once firefox opens, extensions only appear in extension manager and do not function on this profile (which is an administrator profile)
4. click on options for the extension in extension manager and firefox locks up.
How are you installing them? Are there any errors with the text extension in the JavaScript console (e.g. Tools -> JavaScript Console)?
(Reporter)

Comment 2

12 years ago
I am visiting the websites like the Extension website for Firefox and trying to install Reveal for instance... I click on the link and allow it then it opens the Extenstions console and says will be installed when Firefox is restarted.
and "Are there any errors with the text extension in the JavaScript console (e.g. Tools -> JavaScript Console)?"
(Reporter)

Comment 4

12 years ago
No, I am not receiving any errors.  The function of installing the new extension works fine, but after the restart of Firefox the extensions dont work, yet they appear in the extensions window.  And if you try to click on the options button for an extension Firefox freezes.
There have been several bugs with similar symptom that have fixed since 1.5... regretfully, the branch and trunk aren't in a state where I am comfortable with asking you to try it out with a latest nightly to see if this bug is already resolved.

I would expect there would be at the very least errors in the JavaScript relating to chrome errors from the information you have provided so I am at a loss as to why this is happening to you and there are no other bug reports with this same symptom.

Can you zip up your profile's extensions directory along with the extensions.rdf, extensions.cache, and extensions.ini files that are located inside your profile's directory and email them to me? Chances are the compressed file would be too big to attach to this bug.
http://www.mozilla.org/support/firefox/profile

Michael, will you be able to provide the requested files in comment #5?
(Reporter)

Comment 7

12 years ago
(In reply to comment #6)
> Michael, will you be able to provide the requested files in comment #5?
> 

Yes, I am sorry for the delay in me sending the files.  I will forward them this evening when I get home to the computer that is having the issues.
Michael, I received the files and though I was not able to reproduce it I do see some oddities.

First, the extensions dir has the hidden attribute set... try selecting it in explorer, from the context menu select properties, on the general tab deselect hidden, click ok and when prompted apply to this folder and all sub-folders. I don't think this will fix it but this is the first profile I have ran across that had the hidden attribute on the extensions dir so it may be related.

Second, the extensions.rdf is not complete though the other files have the info for all the extensions and themes installed. Type about:config in the url bar and add a new boolean pref of extensions.logging.enabled with a value of true. Try deleting the extensions.rdf and then starting Firefox... the file will be regenerated on startup. If the problem still persists, look in the JavaScript console for any errors with the word extension in it and if there are any post them to this bug and email me the new extensions.rdf - I'd like to see if anything has changed.

Have you ever launched Firefox to install extensions using run as using this profile?
Michael, can you perform the steps outlined and provide the info asked for in comment #8?
No reply from reporter... resolving -> wfm. If you can perform the steps outlined and provide the info asked for in comment #8 please reopen or file a new bug if you are still experiencing this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.