Constant-widths font not printed as constant width (on paper), and also a DL rendering problem.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Lloyd ALLISON, Unassigned)

Tracking

1.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050925 Firefox/1.0.4 (Debian package 1.0.4-2sarge5)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050925 Firefox/1.0.4 (Debian package 1.0.4-2sarge5)

1: constant-width fonts, in PRE TT and CODE tags,
are rendered correctly on the screen but, for PRE and TT,
are printed as proportional-width fonts on paper --
thus destroying "ascii-art" layout. However, CODE text does
print as constant-width!  See
http://www.csse.monash.edu.au/~lloyd/test.html

--

2: DL DT DD tag layout is not rendered correctly if the
font size is changed from the default -- same URL gives an example
http://www.csse.monash.edu.au/~lloyd/test.html

--

I would not be surprised if the first problem was something
to do with the environment, rather than firefox as such,
but I do not know that and I cannot think what on earth it would be.
Neither problem occurs with Mozilla 4.79 on Solaris.


-Lloyd

Reproducible: Always

Actual Results:  
1: Any PRE ... /PRE text that needs constant width font; click on 'print'.

2: Rather than
  DT
      DD
  DT
      DD
say, a DL DT DD set is rendered as
  DT  DD
  DT  DD
when the font size is changed from the default.


Expected Results:  
1: Constant-width text rendered on the screen,
proportional-width font printed.

Comment 1

13 years ago
don't have a printer handy here but have you tried this with latest release 1.5.0.1 ? 
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060324 Firefox/1.6a1 - Build ID: 0000000000
Works fine for me. Can you please try to reproduce this with the latest version of Firefox?
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.0 Branch

Comment 4

11 years ago
On Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a6pre) Gecko/20070623 Minefield/3.0a6pre here, it doesn't even display correctly, because of bug 379886.
WFM with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5pre) Gecko/20070623 BonEcho/2.0.0.5pre

In case this bug can be reproduced on trunk, it should depend on bug 379886.

Comment 5

11 years ago
(In reply to comment #4)
PS: I used Print Preview to check.

Comment 6

11 years ago
On a Windows trunk build the testcase looks fine. I'll try and check the Linux trunk soon.

Comment 7

11 years ago
Looks fine in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2007121204 Minefield/3.0b3pre

Resolving works for me based on comments
WFM, 20081230 Minefield/3.2a1pre on Linux.

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.