"blue" skin: depressed chrome buttons drawn incorrectly

VERIFIED WONTFIX

Status

()

P4
normal
VERIFIED WONTFIX
19 years ago
17 years ago

People

(Reporter: jruderman, Assigned: joki)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed|worksforme?)

(Reporter)

Description

19 years ago
There are several ways to produce similar bugs in which not all of a toolbar 
button is erased before it is moved down into the "depressed" state.  One way 
is to click-drag out of an enabled button.  Another is to click "forward" onto 
the last page in history, in which case the button seems to end up in a 
depressed + disabled state.  Both of these cosmetic problems go away if you alt-
tab away and back.  Bug 33144 is somewhat related (deals with alt-tab while 
button is depressed).

Comment 1

19 years ago
Possibly a duplicate of bug #32756.

By the way, davidr8 ... what build are you testing? 
(Reporter)

Comment 2

19 years ago
2000 032308

Comment 3

19 years ago
reassigning to evaughan as p4 for m17
Assignee: trudelle → evaughan
Priority: P3 → P4
Target Milestone: --- → M17

Comment 4

19 years ago
You territory
Assignee: evaughan → joki
(Assignee)

Comment 5

19 years ago
Adding [STATE] keyword to bugs dealing with bad internal state created by lost 
or overridden events.
Status: NEW → ASSIGNED
Summary: Depressed chrome buttons drawn incorrectly → [STATE] Depressed chrome buttons drawn incorrectly
(Assignee)

Comment 6

19 years ago
Updating Milestone to M18.
Target Milestone: M17 → M18
This bug has been marked "future" because the original netscape engineer
working on this is over-burdened. If you feel this is an error, that you or
another known resource will be working on this bug,or if it blocks your work in
some way -- please attach your concern to the bug for reconsideration.
Target Milestone: M18 → Future

Comment 8

18 years ago
Actually, I'm not seeing this on any platform as described above. jesse: is
this fixed, or is there some particular place where you still see this 
happening? 
Whiteboard: fixed|worksforme?
(Reporter)

Comment 9

18 years ago
When I click a navigation-toolbar button in the blue skin in 2000 093008, some 
white residue is left at the top and left.  I'm pretty sure that's the same 
problem I was talking about in March (based on the summary).  

Adding "blue" to summary, and removing [state] because the drawing problems 
mentioned in my first comment have gone away.  Should this be moved to 
the "themes" component?
Summary: [STATE] Depressed chrome buttons drawn incorrectly → "blue" skin: depressed chrome buttons drawn incorrectly

Comment 10

18 years ago
The Blue theme is no longer being worked on...
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 11

17 years ago
VERIFIED:
Netscape 6.1 RTM is about to ship

Comment 12

17 years ago
verified wontfix
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.