Make it easier for ISPs to hook into Thunderbird

RESOLVED DUPLICATE of bug 360702

Status

RESOLVED DUPLICATE of bug 360702
13 years ago
12 years ago

People

(Reporter: mscott, Assigned: mscott)

Tracking

Trunk
Thunderbird2.0
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

13 years ago
Right now we've got our ispdata rdf files which ISPs can generate and place in bin\defaults\isp in customized versions of Thunderbird.

It would be great if we extended this mechanism to make the installation of these rdf files easier. 

Options could include:

1) Make it so you can wrap your .rdf file in an extension XPI (could even be hosted on addons). With this, a user just has to install an extension into an existing thunderbird binary to get pre-configured e-mail support for an ISP. 

2) We could ship with a couple .rdf files for some of the larger ISP / webmail providers who offer free POP/IMAP access. i.e. gmail. (I think yahoo still charges for POP access?)

Comment 1

13 years ago
How about adding UI in the Account Wizard with a list of pre-selected and pre-configured ISPs? That way, the user just selects his ISP, enters his UN (and PW) and is done. I would suspect that most users get Thunderbird from a "generic" source (e.g., magazine CD-ROM or www.mozilla.org) rather than from their ISP.

PS. Mozilla.com could then charge ISPs €$ for inclusion in the list. ;-)

Comment 2

13 years ago
(In reply to comment #1)

The default selection could/should be "Other", which allows the user to enter the POP/IMAP/SMTP Server settings themselves.

Comment 3

13 years ago
(In reply to comment #1)

Selecting a pre-defined ISP should still show that ISP's settings (but they would not be editable, i.e., grayed-out). It would keep the UI consistent with the "Other" seletion and provides useful information/education for the user.

Comment 4

13 years ago
See also bug #333527 (thanks Mike). I believe that the method suggested there solves the issue discussed here in a broader, more general way. However, it also requires more of a rewrite of the account manager.  

Comment 5

12 years ago
(In reply to comment #1)
> How about adding UI in the Account Wizard with a list of pre-selected and
> pre-configured ISPs? That way, the user just selects his ISP, enters his UN
> (and PW) and is done. I would suspect that most users get Thunderbird from a
> "generic" source (e.g., magazine CD-ROM or www.mozilla.org) rather than from
> their ISP.
> 
> PS. Mozilla.com could then charge ISPs €$ for inclusion in the list. ;-)
> 

I think something must be done in order to make it easier for people who don't have a lot of knowledge about computers to create a new account. 
A big problem for them is: If you configure a second or third E-mail-account, you cannot enter the information for the SMTP-Server!

Comment 6

12 years ago
(In reply to comment #1)
> How about adding UI in the Account Wizard with a list of pre-selected and
> pre-configured ISPs? 

There are 200+ countries in the world, with anything between 5 and 5000 ISPs each. Creating and maintaining a list of them would be a project bigger than mozilla itself; finding your ISP among thousands and thousands in a drop-down menu would be harder than finding dark matter with the help of a wish bone. 

I still think that the conf.d idea in bug #333527 is the cleanest and most flexible. 
(Assignee)

Comment 7

12 years ago
Hey guys, in an act of brilliance, I forgot that I filed this bug and ended up filing another one in which I've attached a working patch! Bug 360702 is really a dupe of this but with a patch. Now it's trivial for extensions to drop in ISP files for the account manager. Like Peter, I think it would be interesting to have someone hook into the account manager that lets you find / search for your isp settings in these files.

I'm going to dupe this bug, feel free to add yourselves to 360702.

*** This bug has been marked as a duplicate of 360702 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.