Slow tab switching and slow scrolling with heavy flash

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: pekayz, Unassigned)

Tracking

({perf})

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060321 Firefox/2.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060321 Firefox/2.0a1

This website I gave (sky news) has alot of Flash objects in the webpages, I goto articles, sometimes browsing on the articles there I can't even do (using mousewheel or the arrow keys or scrollbar, have to use highlighting text to go down. When this long slowness is present, if I switch tabs, takes 20 seconds to switch.

If I close this site, firefox's normal performancing speeds returns to normal. I assume its the amount of flash objects on the page that freezes up only some parts of Firefox, not all of it.

Reproducible: Sometimes

Steps to Reproduce:
1. Logon http://www.sky.com/skynews/home
2. Navigate around, especially the articles
3. Try to see if scrolling doesn't work, if tabs take time to switch

Actual Results:  
Slow tab transition and/or scrolling the page affected by bad speed.

Expected Results:  
Normal scrolling as usual, tabs to switch at a normal speed

Comment 1

12 years ago
(In reply to comment #0)
> I assume its the amount of flash objects on the page that freezes up only some
> parts of Firefox, not all of it.

Duplicate of Core bug 238935?

Comment 2

11 years ago
pekyz, do you see this using Firefox 2 ?
If you look at the page source, can you find wmode or opaque ?

zug in comment #1:
> (In reply to comment #0)
> > I assume its the amount of flash objects on the page that freezes up only some
> > parts of Firefox, not all of it.
> 
> Duplicate of Core bug 238935?

aka bug 341380
Keywords: perf
Summary: Very slow tab switching and/or no scrolling available → Slow tab switching and slow scrolling with heavy flash

Comment 3

11 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a7pre)
Gecko/2007071705 Minefield/3.0a7pre and flash player 9.0 r60
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 2.0 Branch
It's highly likely that bug 342810 will help out a great deal here (it's already on the trunk, and working well!).  This will make Firefox 3.
You need to log in before you can comment on or make changes to this bug.