URL in the address bar not updated with the current page URL

RESOLVED INVALID

Status

SeaMonkey
General
--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Olivier Vit (just a reporter), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.9a1) Gecko/20060323 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.9a1) Gecko/20060323 SeaMonkey/1.5a

When multiple tabs are active in a browser window, the address bar of the first tab window (top) isn't updated with the URL of the page being browsed

Reproducible: Always

Steps to Reproduce:
Open a new browser window on google.com
Perform a search
(Notice that the URL in the address bar is still http://www.google.com without search parameters)
Open the first result in a new tab, go to the second tab, look at the address bar : OK
Go back to the first tab
Open the second result in the current tab (first one) : the address bar is still displaying the URL of the second tab !!




Expected Results:  
In each window, display the url of the page being displayed :-)

In the Javascript Console :

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.canGoBack]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://navigator/content/nsBrowserStatusHandler.js :: anonymous :: line 306"  data: no]
(Reporter)

Comment 1

12 years ago
related to 331436 fix ???
(Reporter)

Comment 2

12 years ago
Probably a related problem: Impossible to close the window of the first tab

Error: this.mTabListeners[i] has no properties
Source File: chrome://global/content/bindings/tabbrowser.xml
Line: 769

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebProgress.removeProgressListener]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/tabbrowser.xml :: removeTab :: line 1028"  data: no]

Comment 3

12 years ago
Duplicate of Core bug 330311?
(Reporter)

Comment 4

12 years ago
Was probably due to the installation failure of the needlesearch extension, leading to other problems in the loading of the app
Managed to unistall the extension, now everything is fine
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.