Dependency Graph for Bug 330700 Crashes Bugzilla

RESOLVED DUPLICATE of bug 102622

Status

()

Bugzilla
Bugzilla-General
RESOLVED DUPLICATE of bug 102622
13 years ago
13 years ago

People

(Reporter: Mark Bickford, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Bug 330700 (Bugzilla 3.0 Roadmap) has an admittedly complex set of dependencies.  When clicking on the "View Dependency Graph" link, the app spins for several minutes and then crashes with an HTTP 500 Internal Server Error.

Reproducible: Always

Steps to Reproduce:
1. Go to bug 330700 at bugzilla.mozilla.org
2. Click on "View Dependency Chart"
3. Wait for Server Error 500 to eventually appear

Actual Results:  
Throbber spun for several minutes, and then the page crashed.

Expected Results:  
Dependency chart should appear, or else a screen (in a short time, not 5+ minutes) with a notification that the graph would not be able to be presented.

Crash happens in showdependencygraph.cgi.  I'm marking this as Normal rather than Critical since the depth of the dependency tree for this bug may be unusual.

Comment 1

13 years ago
I think this may be a bmo-specific problem. I've seen dependency graphs fail somewhat often on bmo. Either that or it's some bug that bmo exposes by being a large installation.
OS: Windows 2000 → All
Hardware: PC → All
Version: unspecified → 2.20
it's the latter.  People have a tendency to create lots of (meaningless?) metabugs, and it causes the dependencygraphs to get downright huge.

The "crash" is because we have a cron job that kills off dot processes that last more than 6 minutes (because the server will die if we don't).

Comment 3

13 years ago
The problem we have here is what myk describes in bug 102622 comment 0.

*** This bug has been marked as a duplicate of 102622 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.