With multiple profiles, mail window opens in background and doesn't take focus



Mail Window Front End
12 years ago
4 years ago


(Reporter: Jim, Unassigned)



Mac OS X

Firefox Tracking Flags

(Not tracked)




12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/312.8 (KHTML, like Gecko) Safari/312.6
Build Identifier: Thunderbird version 3 alpha 1 (20060323)

I am using multiple profiles with the profile selection dialog.  When I choose a profile on startup, the main window then appears in the background and has to be brought to the foreground manually.  Additionally, some focus problems then make it difficult to enter a password without a bit more manipulation.

Reproducible: Always

Steps to Reproduce:
1. Use thunderbird -profilemanager to create more than one profile
2. Do not click the "Don't ask at startup" checkbox - you want the profile selection dialog box to show
3. Configure the new profile for an IMAP account that requires a password
4. Quit Thunderbird
5. Restart Thunderbird by double clicking its icon
6. Profile selection dialog should show, in the foreground, with focus
7. Select a profile or hit return to get the default selection
8. Thunderbird mail window appears, but not in the foreground - the icon will bounce in the dock
    (This is really the bug here - the window should be in the foreground, but there are further
     issues that cause this to be more of a problem than this simple inconvenience)
9. Use alt-tab to bring the window to the foreground, you will see the password dialog showing
10. Try to type the password, but the dialog does not have focus.
11. Try to click on the dialog or in the text field and focus will not be transferred

Actual Results:  
Window appears in background and is difficult to get keyboard focus into the password text entry field without a lot of additional manipulation.

Expected Results:  
After selecting a profile, the window should appear in the foreground with the password dialog already focused and awaiting password entry.

This is on a Powerbook G4 with Mac OS 10.3.9 with all Software Updates except for the latest Quicktime and iTunes.

Originally, on Thunderbird 1.5 I never found a work-around once I got past step 8 above.  I also couldn't quit Thunderbird without using force quit on its icon in the dock.  The only way I could run Thunderbird would be to be quick with my fingers and alt-tab to Thunderbird before it displayed its blocking password entry dialog, which required careful timing.

On the nightly build (3alpha1), I was able to find a couple of work-arounds that make this less of a problem, though still a huge annoyance.  With this latest build you can alt-tab away from TB and then alt-tab back and the focus should be in the password field.  Or, you can click on the TB main window titlebar and the dialog should then get focus.  Also, Command-Q now works in that state.

But, the existance of the work-arounds is still secondary to the fact that the window appears in the background instead of the foreground.  Depending on the other apps running at the time, it may not even be visible since it will be hidden behind the windows of other applications.  The focus problems just make an annoying situation that much worse.

Comment 1

12 years ago
bug 318585?

Comment 2

11 years ago
do you still see this problem using newest trunk?  Is it a dupe of bug 318585?
Component: Account Manager → General
QA Contact: account-manager → general
Version: unspecified → Trunk

Comment 3

11 years ago
I've still seen the problem I described in 331626 running "version 3 alpha 1 (20060326)".  I do not see the problem described in 318585 so I doubt it is due to the same underlying cause.

I tried using the "Check for Updates" link, but it seemed to hang without updating, so I went and manually downloaded the "nightly build" which was "version 3.0a1 (20070501)" and this new version no longer has the problem so it looks like it got fixed somewhere in the last year or so...

Comment 4

11 years ago
Just to confirm my comment above - I was not able to reproduce 318585 on either build, including the one where I could still reproduce this bug, so this is not a duplicate.

Comment 5

11 years ago
The new version I downloaded is full of repaint bugs and I find it unusable for day to day work.  I'm likely to downgrade back to the previous release as, other than the focus bug on startup which had a workaround, it at least worked for day to day email...


10 years ago
Keywords: qawanted


10 years ago
Assignee: mscott → nobody

Comment 6

8 years ago
Mike can you reproduce?

Comment 7

8 years ago
This doesn't happen for me with the versions I currently have installed (Eudora 8.0b7, Eudora 8.0b8, TB3.1a1pre-20091206).  I use a separate profile for each.  I don't have an IMAP account configured that requires a password (actually, I do -- but it's not a valid account), but all my POP accounts do.

I don't have TB/Eudora set to be the "default client" and have "Always ask at startup" enabled, so that may have some effect (although I doubt it).

This has happened in 3.0 for one 10.6.x user; see http://getsatisfaction.com/mozilla_messaging/topics/osx_tb_opens_in_background (and the bugs referenced therein).


8 years ago
Component: General → Mail Window Front End
QA Contact: general → front-end

Comment 8

4 years ago
I think Jim is gone.
WFM based on comment 7
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.