https://survey.mozilla.com/ doesn't have a Thunderbird-specific survey

VERIFIED FIXED

Status

Thunderbird
General
--
critical
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: marcia, Assigned: morgamic)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
Seeing using the Thunderbird 1.5.0.2 candidate build. When I uninstall Thunderbird I get the dialog box that asks me to fill out the survey, yet the page I go to is Firefox-specific. We need a Thunderbird specific survey on that page.
(Reporter)

Comment 1

12 years ago
Adding a few folks to the cc list who worked on the original bug - https://bugzilla.mozilla.org/show_bug.cgi?id=322884.
(Assignee)

Comment 2

12 years ago
I created the original, but wasn't aware it was in the Thunderbird installer as well.  All the mocks I had were for Firefox only.

We can add an application table and switch sets of intent/issue texts based on application -- it's something I can work on while I'm in town next week.

What's the timeline on this?  Before 1.5.0.2?

Comment 3

12 years ago
Duping to 322884 since there is a discussion ongoing tehre about TB uninstall

*** This bug has been marked as a duplicate of 322884 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

12 years ago
Reopening - talked to Rafael. We will use this bug to track getting a Thunderbird specific page up by the time we ship. Today when I installed the 1.5.0.2 build the  survey goes to the Firefox page.

Related bugs are https://bugzilla.mozilla.org/show_bug.cgi?id=320505
Status: RESOLVED → REOPENED
Flags: blocking1.8.0.2?
Resolution: DUPLICATE → ---
(Reporter)

Updated

12 years ago
Assignee: mscott → rebron
Status: REOPENED → NEW

Comment 5

12 years ago
Would it be useful/helpful if I wrote an html page that had a thunderbird exit survey based on the html visible on https://survey.mozilla.com/?
(Assignee)

Comment 6

12 years ago
Hey Scott, yes, having a mock would help -- see the mock at the beginning of bug 322884 that was provided for Firefox.

We've managed to clear up most of the AMO bug fixes this week, so there is time to finish up the survey this weekend.

I'll set up the app switching, and we can plug in the questions when we get them.  Sound good?
Assignee: rebron → morgamic
Severity: normal → critical

Comment 7

12 years ago
Created attachment 218489 [details]
first cut at an exit survey

that sounds like a good plan mike.
(Assignee)

Comment 8

12 years ago
Thunderbird-specific issues/intends were entered in -- see if this looks right:
https://update-staging.mozilla.org/~morgamic/survey/webroot/1/Mozilla%20Thunderbird/1.5%20(en-US)/exit.html

We will push it into production if it looks alright.  Doing so will require some SQL adjustments for adding application-specific relationships but won't affect existing data.
Status: NEW → ASSIGNED

Comment 9

12 years ago
This looks great Mike. One minor text change that came from rafael:

we should change:
(gmail, yahoo, etc)
to
(Yahoo!Mail, AOL, Gmail, Hotmaill, other) 

Thanks for hooking this up!

Comment 10

12 years ago
Mike, do you think this will be ready to go for tomorrow? 
(Assignee)

Comment 11

12 years ago
Scott, will work with infra to get it up and running this AM.  :)
(Assignee)

Updated

12 years ago
Depends on: 334659
(Assignee)

Comment 12

12 years ago
Created attachment 219010 [details] [diff] [review]
Updated value for one of the intend lines, per mscott.
Attachment #218489 - Attachment is obsolete: true
(Assignee)

Comment 13

12 years ago
Comment on attachment 219010 [details] [diff] [review]
Updated value for one of the intend lines, per mscott.

Wrong bug... sorry.
Attachment #219010 - Attachment is obsolete: true
(Assignee)

Updated

12 years ago
Attachment #218489 - Attachment is obsolete: false
(Assignee)

Comment 14

12 years ago
Should be updated in production, testing should be possible now from the Tb uninstaller:
https://survey.mozilla.com/1/Mozilla%20Thunderbird/1.5%20(en-US)/exit.html
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED

Comment 15

12 years ago
Excellent. Thanks everyone.

Question, I don't know if this is important or not but https://survey.mozilla.com/ used to take me to the firefox survey page. Now it redirects over to to http://www.mozilla.com/support/. Maybe a non issue, just thought I'd point it out.  
(Assignee)

Comment 16

12 years ago
(In reply to comment #15)
> Question, I don't know if this is important or not but
> https://survey.mozilla.com/ used to take me to the firefox survey page. Now it
> redirects over to to http://www.mozilla.com/support/. Maybe a non issue, just
> thought I'd point it out.  
Yes, in the last update I put in this redirect in the event where no application is defined, which means the site is being accessed directly and not from the installer.  Would this be a problem?  I was under the impression the survey was specifically people uninstalling our products, so a direct link to the root of the domain isn't helpful to us -- since we can't associate it with any particular product/version/locale.  It ends up being an anonymous blog post about anything Mozilla.

Comment 17

12 years ago
I don't think that's a problem, just noticing the difference.
Verified with Thunderbird 1.5.0.2 
Status: RESOLVED → VERIFIED
(Assignee)

Comment 19

12 years ago
(In reply to comment #17)
> I don't think that's a problem, just noticing the difference.
Okay -- just checking.  :)

Flags: blocking1.8.0.2?
You need to log in before you can comment on or make changes to this bug.