Third Party Cookie not written when written using a JS Image object

VERIFIED INVALID

Status

VERIFIED INVALID
13 years ago
12 years ago

People

(Reporter: justin, Assigned: mikepinkerton)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0

When attempting to write out a third party cookie via a JavaScript Image() object, its not accepted by Camino. No preference appears to be blocking it, and it does work in Mozilla Firefox 1.5 (on both Windows and Mac).



Reproducible: Always

Steps to Reproduce:
Using provided testcase:
1. Go to provided URL
2. Refresh, and see if number increments.
Otherwise:
1. Write a third party (cookie from a different domain) by loading an image which sets the cookie using the JavaScript Image object.
2. Attempt the read cookie, and see if it exists or not.

Actual Results:  
Cookie isn't set

Expected Results:  
Cookie is set.

It works on Mozilla Firefox

Comment 1

13 years ago
Something is screwed up on the server end, because I never even get *asked* if I want to allow a cookie (if "Ask" is checked in prefs).

cl

Comment 2

12 years ago
Closing as INVALID (not Camino's fault), per comment 1 and this bug's complete lack of updates since its filing.

cl
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.