Add names to credits

RESOLVED FIXED in Firefox 2

Status

()

Firefox
General
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: jwatt, Assigned: mconnor)

Tracking

({fixed1.8.1})

unspecified
Firefox 2
fixed1.8.1
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments, 2 obsolete attachments)

As discussed on IRC, here's a bug for adding names to the Mozilla Firefox credits. Some to get you started:

Stuart Parmenter
Tim Rowley
Jonathan Watt
(Reporter)

Updated

12 years ago
Flags: blocking-firefox2?
(Reporter)

Updated

12 years ago
Assignee: mconners → mconnor
stuart was already added in bug 330784 :)
(Reporter)

Comment 2

12 years ago
Ah, I thought he meant stuart still hadn't been added, but he must have meant before the a1.
(Assignee)

Comment 3

12 years ago
Here's the plan of record:

Use this bug until close to the end of b2 to track names, and then make the change.  Please suggest names in the bug as appropriate.
Status: NEW → ASSIGNED
Flags: blocking-firefox2? → blocking-firefox2+
Target Milestone: --- → Firefox 2 beta2
(Assignee)

Comment 4

12 years ago
Robert Sayrer
Dietrich Ayala
Seth Spitzer
Whiteboard: [SWAG: 0.5d]
Christian Biesinger
(Assignee)

Comment 6

12 years ago
pushing out non-critical-path bugs to b2
(Assignee)

Updated

12 years ago
Whiteboard: [SWAG: 0.5d] → [SWAG: 0.5d] [mustfix]
I'm already in there, but what about tony, pkasting, brettw?
Here are some people @Google who have contributed to Firefox 2 in a variety of ways:

Peter Kasting
Brett Wilson
Annie Sullivan
Joe Hughes
Pam Greene
Marria Nazif
Brian Rakowski
Fritz Schneider
Tony Chang
Andrea Knight
Simon Bünzli
(Assignee)

Comment 12

12 years ago
Will do this once we put beta2 to bed
Whiteboard: [SWAG: 0.5d] [mustfix] → [mustfix][post beta]
Target Milestone: Firefox 2 beta2 → Firefox 2
*** Bug 344662 has been marked as a duplicate of this bug. ***
From bug 344662
Ximon Eighteen, NSIS
Justin Frankel, NSIS
Dave Laundon, NSIS
Robert Rainwater, NSIS
Amir Szekely, NSIS
Joost Verburg, NSIS

Comment 16

12 years ago
Mike Beltzner
Paul Kim
Deb Richardson
Eric Shepherd
Sherman Dickman
Basil Hashem
Mary Colvig
Phil Schwan
Tristan Nitot
Gen Kanai
Paul Reed
Robert Helmer
Igor Bukanov
Reed Loden
Michael Wu
Joey Minta
Mark Pilgrim
Mike Schroepfer
John Lilly
Graydon Hoare
Neil Deakin
moz_bug_r_a4
Masatoshi Kimura
Ere Maijala

Comment 18

12 years ago
*** Bug 347832 has been marked as a duplicate of this bug. ***
Spark PR is still listed as the PR agency in the credits. I believe that should be corrected to A&R Partners, or they should at least be added.
(In reply to comment #17)
> Paul Reed

Pretty sure that should be "J. Paul Reed" instead.
shouldn't this list of people be merged with the about:credits list?
(In reply to comment #21)
> shouldn't this list of people be merged with the about:credits list?

What do you mean exactly? Are you saying that these people be put on the about:credits list, too, or something else?

about:credits != Firefox Credits

The people on the Firefox Credits page should be in about:credits, but not visa-versa.
what I mean is that I don't understand the distinction between the lists, what makes somebody being part of about:credits and what makes somebody being part of credits.xhtml. It is clear to me that Firefox wouldn't exist without the whole collaborative work of the people cited in about:credits.

Another thing is that all localizers should be in the credits list since Firefox wouldn't exist without them outside of English-speaking countries. Pike is listed in none of the lists for instance and he works full-time on Firefox.

The credits.xhtml list is pretty limited compared to the number of people that worked on Firefox at all levels, coding, theme, translation, marketing, documentation... I guess there are rules that say "about:credits list that kind of contributors" and "credits.xhtml lists that subset of the general list", but AFAIK the rules are not explained anywhere.

It is also strange to see mozillazine in the list but not spreadfirefox, nor geckozone.org nor aviary.pl nor firefox-browser.de... well, you get the idea.
(Assignee)

Comment 24

12 years ago
(In reply to comment #23)
> what I mean is that I don't understand the distinction between the lists, what
> makes somebody being part of about:credits and what makes somebody being part
> of credits.xhtml. It is clear to me that Firefox wouldn't exist without the
> whole collaborative work of the people cited in about:credits.

See below.

> Another thing is that all localizers should be in the credits list since
> Firefox wouldn't exist without them outside of English-speaking countries. Pike
> is listed in none of the lists for instance and he works full-time on Firefox.

That'd be an oversight, he should be there, without a doubt.

> The credits.xhtml list is pretty limited compared to the number of people that
> worked on Firefox at all levels, coding, theme, translation, marketing,
> documentation... I guess there are rules that say "about:credits list that kind
> of contributors" and "credits.xhtml lists that subset of the general list", but
> AFAIK the rules are not explained anywhere.

I should have cross-posted the points I made in another bug where it was proposed to kill the separate list.  Will do so as a clean comment.

> It is also strange to see mozillazine in the list but not spreadfirefox, nor
> geckozone.org nor aviary.pl nor firefox-browser.de... well, you get the idea.

Really, we need to update the supporting org list as well, I was admittedly focused in the short term on recognizing individual contributors.  More shortly on how we've been looking at this.
(Assignee)

Comment 25

12 years ago
A bit of summary/crosspost from newsgroup and bug discussions (i.e. in the mozilla.org Governance bug):

There are two sets of people we want to thank and give credit to, especially in a large project with a broad history and hopefully broader future:

One is the total collection of everyone who has worked on the project, from the early days leading to Mozilla 1.0, to driving the webtools and other projects (Thunderbird, Sunbird, Chatzilla, etc), to shipping Firefox in different versions.  That is the sum of everyone who has made the project what it is, and what it will become in the future.

The other is the much smaller group of people who made the current release happen.  This is not just true for Firefox, but for any other Mozilla project.  We do not, as a project, do a good job of calling out individual contributions when they are making major contributions (see Axel being missing as a key example).  This is going to be an attempt to change that, by making sure that the people who are making this release happen have that contribution called out.

We think both sets are important enough to recognize, which is why we're driving this.  Please continue to nominate people for inclusion, especially anyone long-overlooked!
(In reply to comment #20)
> (In reply to comment #17)
> > Paul Reed
> 
> Pretty sure that should be "J. Paul Reed" instead.

Just to confirm, "Yes, that's right."

Kthx. ;-)
I propose we also add Dao Gottwald to either about:credits or credits.xhtml for his help with the tabstrip.

Comment 28

12 years ago
Just a quick note we'll be wrapping the bug up shortly - so if you were going to add names now's the time :-).
Axel Hecht should be obviously added, I agree with Pascal on this.

As for the localization teams, they list themselves using the credit.translation entity in credits.dtd in each respective locale.
(Assignee)

Comment 30

12 years ago
Will be attaching a patch which adds the following list.

This combines the old list, minus people known to have left the project, with the nominations here, as well as a list of active contributors gleaned from deep querying of Bugzilla.  Please add comments here, thanks!

Josh Aas
Robert Accettura
Dietrich Ayala
Mitchell Baker
Jason Barnabe
David Baron
Chris Beard
Glen Beasley
Mike Beltzner
Uri Bernstein
Christian Biesinger
Nelson Bolyard
Carsten Book
Igor Bukanov
Simon Bünzli
Regis Caspar
Biswatosh Chakraborty
Tony Chang
Wan-Teh Chang
Ginn Chen
Christian Persch
Bob Clary
Mary Colvig
Mike Connor
Chris Cooper
Michael Daumling
Neil Deakin
Sherman Dickman
Steven Donner
Asa Dotzler
Rafael Ebron
Brendan Eich
Ximon Eighteen
Kai Engert
Steve England
Darin Fisher
Ryan Flint
Justin Frankel
Simon Fraser
Eli Friedman
Mike Gao
Steven Garrity
Michael Glenn
Jay Goldman
Ben Goodger
Pam Greene
Adam Guthrie
Vidar Haarr
Mark Hammond
Basil Hashem
Axel Hecht
Robert Helmer
Jon Hicks
Ian Hickson
Graydon Hoare
Chris Hofmann
Mike Hommey
Joe Hughes
Ed Hume
Gen Kanai
Blake Kaplan
Michael Kaply
Peter Kasting
Alfred Kayser
Paul Kim
Masatoshi Kimura
Ria Klaasen
Andrea Knight
Marcia Knous
Dave Laundon
Aaron Leventhal
Mark Liddell
John Lilly
Nian Liu
Reed Loden
Robert Longson
Scott MacGregor
Ere Maijala
Sean Martell
Myk Melez
Mark Mentovai
Alex Menzies
Steven Michaud
Bernd Mielke
Joey Minta
Simon Montagu
Scooter Morris
Masayuki Nakano
Marria Nazif
Ian Neal
Tristan Nitot
Robert O'Callahan
Mats Palmgren
Stuart Parmenter
Jay Patel
Igor Pavlov, 7-Zip
Javier Pedemonte
Alfred Peng
Olli Pettay
Chase Phillips
Julien Pierre
Mark Pilgrim
Mike Pinkerton
Nickolay Ponomarev
Feng Qian
Robert Rainwater
Brian Rakowski
Paul Reed
Robert Relyea
Deb Richardson
Phil Ringnalda
Robert Sayrer
Roger B. Sidje
Asaf Romano
Doron Rosenberg
Blake Ross
James Ross
Tim Rowley
Jesse Ruderman
Brian Ryner
Alexander Sack
Hideo Saito
Fritz Schneider
Mike Schroepfer
Phil Schwan
Chris Seawood
Leon Sha
Gavin Sharp
Mike Shaver
Eric Shepherd
Jungshik Shin
Jonas Sicking
Benjamin Smedberg
Jon Smirl
Josh Soref
Seth Spitzer
Johnny Stenback
Luke Stone
Robert Strong
Annie Sullivan
Amir Szekely
Dave Townsend
Ben Turner
Doug Turner
Peter Van der Beken
Peter van der Woude
Daniel Veditz
Michael Ventor
Joost Verburg
Alexei Volkov
Vladimir Vukicevic
Hakan Waara
Jeff Walden
Tracy Walker
Martijn Wargers
Jonathan Watt
Steffen Wilberg
Brett Wilson
Michael Wu
Boris Zbarsky 
(In reply to comment #30)

> Paul Reed

This should be "J. Paul Reed", as per comment #26.
Does dbaron go by "David Baron" or "L. David Baron"?

also, what about Dao Gottwald?

Finally, for Hakan Waara (and others?), I think you are missing an umlaut
sorry, not an umlaut, but å
If we are going to continue to have
Igor Pavlov, 7-Zip

then the following should be
Ximon Eighteen, NSIS
Justin Frankel, NSIS
Dave Laundon, NSIS
Robert Rainwater, NSIS
Amir Szekely, NSIS
Joost Verburg, NSIS

Comment 35

12 years ago
(In reply to comment #33)
> sorry, not an umlaut, but å

Yes, thank you for noticing.
(Assignee)

Comment 36

12 years ago
I think I'd rather take 7-zip out of the list for now, I'm not really looking to identify in this list what people did (though there's the beginning of a project to track community members and their contributions, which should allow people to find this out)

Fixed Håkan

Fixed preed (I had fixed that once, but obviously in the wrong place)

Added Dao
(Assignee)

Comment 37

12 years ago
Created attachment 238263 [details] [diff] [review]
ze patch

Beltzner, please do a quick pass and ensure this looks right, and that I haven't missed anything important.
Attachment #238263 - Flags: review?(beltzner)
(Assignee)

Updated

12 years ago
Whiteboard: [mustfix][post beta] → [has patch][needs review beltzner]
There's a superfluous blank:

> +            <li>Boris Zbarsky </li>

And my name is Dão, actually, but I don't care much.
Thanks for nominating me, Seth.
(Assignee)

Comment 39

12 years ago
Created attachment 238286 [details] [diff] [review]
ze patch v2

I shouldn't be shocked by this, but as soon as you post a patch, people suddenly come out of the woodwork!

changes in v2

Fix removing coop, becuase obviously I can't work a keyboard
Add Rob Campbell, Mic Berman, Majken Connor, Justin Scott, Cameron Roy, Mike Morgan, Wil Clouser, Andrei Hajdukewycz, Justin Fitzhugh
Attachment #238263 - Attachment is obsolete: true
Attachment #238286 - Flags: review?(beltzner)
Attachment #238263 - Flags: review?(beltzner)
(In reply to comment #39)
> Created an attachment (id=238286) [edit]

Christian Persch isn't arranged in alphabetical order:

> +            <li>Ginn Chen</li>
> +            <li>Christian Persch</li>
>              <li>Bob Clary</li>
Comment on attachment 238286 [details] [diff] [review]
ze patch v2

I can't see anything else obvious. Make sure Asa's looked it over, of course ...
Attachment #238286 - Flags: review?(beltzner) → review+
(Assignee)

Comment 42

12 years ago
Comment on attachment 238286 [details] [diff] [review]
ze patch v2

Asa's checked this over, and I'll fix the sort issue on checkin
Attachment #238286 - Flags: approval1.8.1?
Nick Thomas (cf on irc) ?
(Assignee)

Updated

12 years ago
Whiteboard: [has patch][needs review beltzner] → [has patch][needs approval]

Comment 44

12 years ago
Comment on attachment 238286 [details] [diff] [review]
ze patch v2

a=schrep for 181drivers
Attachment #238286 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Comment 45

12 years ago
marking fixed, if there are people I missed, I'll check back tomorrow just to be sure.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [has patch][needs approval]

Comment 46

12 years ago
(In reply to comment #45)
> marking fixed, if there are people I missed, I'll check back tomorrow just to
> be sure.
> 

s/Sayrer/Sayre/
Chris Cooper appears twice now.

            <li>Chris Cooper</li>
            <li>Majken Connor</li>
            <li>Mike Connor</li>
            <li>Chris Cooper</li>

Comment 48

12 years ago
This has mistaken. (v1.22)

Satako Takita Yamaguchi (Chibi)

 --> Satoko Takita Yamaguchi (Chibi)
Created attachment 240698 [details] [diff] [review]
spell chibi-san's name properly!
Attachment #240698 - Flags: review?(mconnor)
(Assignee)

Updated

12 years ago
Attachment #240698 - Flags: review?(mconnor)
Attachment #240698 - Flags: review+
Attachment #240698 - Flags: approval1.8.1+
Created attachment 240702 [details] [diff] [review]
gah, more names: alice, davel, timr, zach, juanb
Attachment #240702 - Flags: review?(gavin.sharp)
Comment on attachment 240702 [details] [diff] [review]
gah, more names: alice, davel, timr, zach, juanb

I checked this in with Alice Nodelman in the right order.
Attachment #240702 - Flags: review?(gavin.sharp) → review+
Comment on attachment 240702 [details] [diff] [review]
gah, more names: alice, davel, timr, zach, juanb

a=me, obviously ;) thanks for the checkin fix, gavin!
Attachment #240702 - Flags: approval1.8.1+

Comment 54

12 years ago
If you're still accepting fixes to name spellings:

Revvr -> 
Revver

These are the folks who provided design/hosting of Firefox Flicks.
(In reply to comment #54)
> If you're still accepting fixes to name spellings:
> 
> Revvr -> 
> Revver
> 
> These are the folks who provided design/hosting of Firefox Flicks.

a=me, gavin to fix as he checks in
Checked in the fix for comment 54.

Comment 57

12 years ago
3 more from Japan please:

  Hiroshi Shimoda
  Kohei Yoshino
  Tomoya Asai

Thank you.
Created attachment 240881 [details] [diff] [review]
Add names from Japan and fix order

Add names from comment #57 and fix ordering.
Attachment #240881 - Flags: review?(mtschrep)
Attachment #240881 - Flags: approval1.8.1?
Since we seem to have perennial ordering problems, I decided to check the alphabetization of the current MOZILLA_1_8_BRANCH credits.xhtml using (gasp!) a computer.  Lowly little /bin/sort caught the two mistakes you correct in attachment 240881 [details] [diff] [review] (Gao after Gansky, Sidje down to between Sicking and Smedberg), and also one other (Prescott after Ponomarev).  (That's assuming that all the names are alphabetized by the correct word within them, something that computers aren't so good at.)

So you might want to also switch Prescott and Ponomarev.

Comment 60

12 years ago
Comment on attachment 240881 [details] [diff] [review]
Add names from Japan and fix order

Approved for RC2.
Attachment #240881 - Flags: review?(mtschrep)
Attachment #240881 - Flags: review?(mconnor)
Attachment #240881 - Flags: approval1.8.1?
Attachment #240881 - Flags: approval1.8.1+
Created attachment 240883 [details] [diff] [review]
Add names from Japan and fix order (take two)

Fix the order completely. Thanks, dbaron!
Attachment #240881 - Attachment is obsolete: true
Attachment #240883 - Flags: review?(mtschrep)
Attachment #240883 - Flags: approval1.8.1?
Attachment #240881 - Flags: review?(mconnor)

Updated

12 years ago
Attachment #240883 - Flags: review?(mtschrep)
Attachment #240883 - Flags: review?(mconnor)
Attachment #240883 - Flags: approval1.8.1?
Attachment #240883 - Flags: approval1.8.1+
mozilla/browser/base/content/credits.xhtml 	1.10.4.13
Seems the last several patches that gavin committed did not land on trunk. Reopening until they land.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [checkin needed]

Comment 64

12 years ago
Stephen Colbert is a Firefox contributor?

http://lxr.mozilla.org/seamonkey/source/browser/base/content/credits.xhtml#258
(Assignee)

Updated

12 years ago
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]

Comment 65

11 years ago
Created attachment 249390 [details] [diff] [review]
Spell Michael's name right...

I just noticed now that my name was on the credits. One small nit though. "Ventor" should be "Ventnor". Everyone makes that mistake with my name. Can this be fixed up on the trunk credits please? :)

(I know I'm far too late for this to happen on the branch, I never thought I'd make it into the credits and I only noticed now)
Attachment #249390 - Flags: review?(gavin.sharp)
(In reply to comment #65)
> Created an attachment (id=249390) [edit]
> Spell Michael's name right...

They also left some people out.  It would be nice to rectify that with this patch.

Comment 67

11 years ago
(In reply to comment #66)
> (In reply to comment #65)
> > Created an attachment (id=249390) [edit]
> > Spell Michael's name right...
> 
> They also left some people out.  It would be nice to rectify that with this
> patch.
> 

Hmm, should this bug be reopened to rectify this?
Comment on attachment 249390 [details] [diff] [review]
Spell Michael's name right...

I fixed both issues, trunk and branch.

mozilla/browser/base/content/credits.xhtml 1.10.4.14
mozilla/browser/base/content/credits.xhtml 1.25
Attachment #249390 - Flags: review?(gavin.sharp) → review+
You need to log in before you can comment on or make changes to this bug.