Memory usage by Firefox with "Google safe browsing" enabled

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
12 years ago
10 years ago

People

(Reporter: Behraad Bahreyni, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

I have been using the extension "Google Safe Browsing" on my Firefox 1.5.0.2. I noticed that the RAm used by Firefox with other extensions that I use is about 20-25MB. However, when I enable "Google Safe Browsing" the amount of used RAM by Firefox slowly increases to 100-105MB, even when a simle Yahoo page is browsed.
I think the "Google Safe Browsing" has a memory leak problem that should be resolved. This could be the problem that is repeatedly mentioned on different sites about the amount of RAM/CPU used by Firefox.

Reproducible: Always

Steps to Reproduce:
1.Install/enable "Google Safe Browsing"
2.Restart Firefox
3.Monitor the RAM usage

Actual Results:  
The RAM used by Firefox slowly (in ~30sec) increases by as much as 80MB.
This isn't an Extension Manager issue since the EM manages the install, upgrade, uninstall, etc. for extensions and has no control whether an extension leaks memory, just uses lots of memory, etc.

cc'ing a couple of google folks to let them know about this and resolving -> invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 2

12 years ago
*** Bug 337944 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.