JS document.write cannot treat multibytes correctly.

VERIFIED INVALID

Status

()

Core
JavaScript Engine
P3
normal
VERIFIED INVALID
19 years ago
17 years ago

People

(Reporter: YONEMURA Kaoru, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
While using independing file(sorry, but I don't know the technical-term to tell 
you, my meaning is *.JS file with Content-Type: application/x-javascript), 
Mozilla cannot display the multibyte character(in Japanese, all (I mean 
Shift_JIS,EUC,JIS,UTF-7,UTF-8 and Uni-Code...) codes are not treated well).

BuildID:2000032308
(Assignee)

Comment 1

19 years ago
Can't find the server, can you try attaching the .js file instead?
(Reporter)

Comment 2

19 years ago
Excuse me, but maybe the server was out of order. please retry now.
(I know the unreaching is because DNS trouble, and now fixed)
(Reporter)

Comment 3

19 years ago
if I wrote it in the html file, this trouble does not occur.
this happens only when using *.js file.
(Reporter)

Comment 4

19 years ago
Uh?
when I re-check it at BuildID:2000032808, this trouble does not happen.
Is this fixed?
(Assignee)

Comment 5

19 years ago
All I get is a bunch of '?' - is that the intent?  Since you said it's now 
working I'm marking this as invalid, but if you think it's still a bug - go 
ahead and re-open it (under the component Internationalization)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 6

18 years ago
Works for Me
Platform: PC
OS: Windows 98
Build # 2000100508 M18 Trunk Build
Marking as Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.