Page background settings are highly unreliable (don't apply as intended)

RESOLVED DUPLICATE of bug 331711

Status

Thunderbird
Message Compose Window
--
major
RESOLVED DUPLICATE of bug 331711
12 years ago
12 years ago

People

(Reporter: Yves Goergen, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Thunderbird 1.5 (20051201)

When editing an HTML e-mail, I cannot add a page background image. When I try, select a local valid JPEG file, confirm the dialogue, nothing happens. The page background remains white. When I set another image, nothing happens, too. Then I tried to save it as a draft, restart Thunderbird and re-open the message. (See my other bug report #331711 from just ago for what happens then.) But for this bug, the draft does contain the selected background image, where the editor didn't. (So here, the editor is somehow broken.) After re-opening the mail, it was messed up, as I said. But at least I could add a background image. Then I found out that the page colours were all wrong (links were black in the draft preview as well as in the page background settings view - even if they were still blue in the message editor (next broken). So I decided to change them to default, but then the background image was gone again. I could set the page colours to custom again, which applied the default colours, but whatever I tried, I couldn't make it show a background image ever again without closing the message window (last broken - or maybe not so last?), which causes a still greater data loss.

What's up with that HTML editor? Is that a feature better left disabled for the public build? I recommended Thunderbird to a good friend of mine 3 days ago, switching her from Outlook Express. But she will make a much greater use of HTML mails than me, so that probably wasn't a good decision. :(

Reproducible: Always

Steps to Reproduce:
(see description)



(Categorised as "critical" because it matches the description "lose data".)

Comment 1

12 years ago
Failure to specify an HTML background as desired does not qualify as a loss 
of data.

I have no problems specifying, loading or sending background images (even from 
a draft, per your other bug).  Do you have any extensions installed?  If so, do you get the same problem after running TB in Safe Mode?
Severity: critical → major
Version: unspecified → 1.5
(Reporter)

Comment 2

12 years ago
I shouldn't have opened two bugs for this... It seems to be the same problem, don't know how I could specify it any better. It works with a new e-mail, but certainly does not with the one from yesterday.

Comment 3

12 years ago
(In reply to comment #2)
> I shouldn't have opened two bugs for this... It seems to be the same problem,
> don't know how I could specify it any better.

OK, duping.

*** This bug has been marked as a duplicate of 331711 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.