azureus and firefox cause heavy hard disk activity, and exit

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: mesti_mudam, Unassigned)

Tracking

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

i have ubuntu 5.10, sun jdk 1.5.0_06 on a pentium m laptop. when i use firefox 1.5.0.1 and azureus 2.4.0.2 simultaneously, the laptop becomes not-responding after maybe 10-20 minutes. and then heavy hard disk activity starts as the laptop becomes not-responding. the mouse hardly moves and ctrl+alt+backspace doesnt work. after maybe 3-5 minutes, both firefox and azureus exit and the laptop becomes  normally-responding again, or none at all and i have to turn the laptop off and on. i have observed this more frequently when there were many tabs open at firefox, and each tab has some web page with multimedia content like videos/music. when using only firefox or only azureus, everything is fine; even when azureus & firefox with a few tabs of simple web pages. it may be something with java. (my firefox has plugins for java, pdf, flash, multimedia(mplayer)).

Reproducible: Always

Steps to Reproduce:
1.start azureus
2.start firefox and open 10+ tabs with web pages containing multimedia
3.in about 10 minutes, laptop becomes not-responding, 3-5 minutes later azureus and firefox exit
Can you try the standard diagnostic? (http://kb.mozillazine.org/Standard_diagnostic_(Firefox))
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Can you try the standard diagnostic?
> (http://kb.mozillazine.org/Standard_diagnostic_(Firefox))
> 

the bug (firefox causing the laptop to not respond, causing heavy hard disk activity and exit) is observed without azureus. it has a problem with xhtml pages i think. to reproduce:

1- get the openoffice.org sdk from http://download.openoffice.org/680/sdk.html
2- in the extracted directory open index.html with firefox
3- click on the "developer's guide" link
4- click on the "spreadsheet documents" link
the bug may appear now, if not
5- open the "writing uno components" link in a NEW tab (you may need to search the current page for that link)
the bug must appear now
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5.0.x Branch
I think this is a Java problem: I have just about exactly the same setup, except I'm using Java Blackdown-1.4.2-02, and I've never come across these symptoms.
When this happens, can you look in the System Monitor and see if anything's using inordinately high amounts of CPU time?
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> I think this is a Java problem: I have just about exactly the same setup,
> except I'm using Java Blackdown-1.4.2-02, and I've never come across these
> symptoms.
> When this happens, can you look in the System Monitor and see if anything's
> using inordinately high amounts of CPU time?
> 

it happens without azureus as well. can you try to open xhtml files (the on im talking about if posible). i have looked in the systems monitor, and when this happens no process seems to be using extreme amounts of cpu time, but waiting time is like 90%.
(Reporter)

Comment 5

12 years ago
i have 512 ram, and 250mb of it is free according to "top". when i open spreadsheet.xhtml from OOo sdk with firefox, free memory drops down to 5mb, and then firefox does "the bug", and exit.
*** Bug 332141 has been marked as a duplicate of this bug. ***
I think this is a system hardware thing. Your specs aren't particularly high, and you're loading several huge pages at the same time there. Can you reproduce this with smaller pages?
(Reporter)

Comment 8

12 years ago
(In reply to comment #7)
> I think this is a system hardware thing. Your specs aren't particularly high,
> and you're loading several huge pages at the same time there. Can you reproduce
> this with smaller pages?
> 

ok. i have 512 mb ram, and no swap. look:

1- when i turn on my laptop and login i have 184 mb free memory, there is no program like chat etc. running (max mem usage: xorg:%4)

2- then i run firefox, free mem drops to 148 mb (mem usage: xorg:%4.2 firefox:%5.4)

3- then from File -> Open File menu of firefox, i open OpenOffice2_SDK_directory/index.html. free mem drops to 144mb (mem usage: xorg:%4.3 firefox:%6.1)

4- then i click on the "developer's guide" link (to html file). free mem and mem usage same

5- then i click on the "Spreadsheet Documents" link (to XHTML file). NOW free mem drops to 14 mb (mem usage: xorg:%65.4 firefox:%5.9)

then if i try to open the link "writing uno components" in a new tab, firefox (& my laptop) becomes not-responding, and firefox exit in about 3-4 minutes and i have 354 mb free mem (xorg:%3) now. if i do the above steps starting from 2 i have:
2- 313 mb free mem
3- 307 mb free mem
4- same (everything is reasonable up to here)
5- 10 mb free mem (xorg:%65.5 again)
then if i try to open the link "writing uno components" in a new tab, firefox (& my laptop) becomes not-responding,but this time it takes very long for firefox to exit and i have to turn off and on my laptop.

so clearly XHTML PAGES MAKE FIREFOX CAUSE XORG TO USE HUGE AMOUNTS OF MEMORY.
and i play games like NeverWinter Nights 1.66, Wolfenstein ET without any problem, so i doubt it is my hardware that is not sufficient.
(Reporter)

Comment 9

12 years ago
and spreadsheet.xhtml and all the files (pictures) in that directory (Spreadsheet) is totally 3.5 mb.
Reporter, do you still see this problem with the latest Firefox 2 and Java? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27

Comment 11

11 years ago
Closing as WFM.  Thanks for reporting.  Feel free to reopen with more information if you still experience this with a recent build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.