Repeat every: problem with saving last Saturday of the month

VERIFIED DUPLICATE of bug 328073

Status

Calendar
Sunbird Only
VERIFIED DUPLICATE of bug 328073
12 years ago
12 years ago

People

(Reporter: Damian Szczepanik, Unassigned)

Tracking

Sunbird 0.3a1
x86
Windows XP

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

When I check "repeat every" and set "last saterday of the month" sometimes (depends of date) after reopening event "last saterday..." is not set

Reproducible: Always

Steps to Reproduce:
1. create event
2. set date from 2006-03-25 22:00 to 2006-03-25 23:00
3. move to recurrence tab
4. check repeat every and change to: 12 months
5. switch radio to "Last Saturday of the month"
6. Press OK
7. Open created event and switch to second tab: radio "Last Saturdy..." is not selected - now "On the 20th" is selected
Actual Results:  
see last of step to reproduce

Expected Results:  
"Last Saturday of the month" should be selected

Sometimes it works fine, so I give you date, when you can reprocude this scenario
(Reporter)

Updated

12 years ago
Version: unspecified → Sunbird 0.3a1
Couldn't reproduce this, so WFM.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060329 Mozilla Sunbird/0.3a1+

Comment 2

12 years ago
(In reply to comment #1)
> Couldn't reproduce this, so WFM.
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060329
> Mozilla Sunbird/0.3a1+
> 
WFM too.  Marking as such.  Thanks for testing, Martin
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

12 years ago
I've checked it on polish version of Sunbird (another PC) and has the same problem

So I would like to add point:
0. delete profile and create new

and of course in 7th should be 25 of March, but I think it is clear

What is your currently result?
I also see, that you have some newer version:
Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.9a1) Gecko/20051104 Mozilla Sunbird/0.3a1
I do not have plus at the end of version, and you Gecko is newer. Please use the same version, because if you can not reprocude it via newer Gecko, that means that this bug has been solved by someone else.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

*** This bug has been marked as a duplicate of 328073 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE

Comment 5

12 years ago
(In reply to comment #3)

If you see the problem in an old version of Sunbird (your Sunbird/0.3a1 (20051104) build) but the problem does not exist in a current developer version (Sunbird/0.3a1+ (20060329)) that is called development progress. That means that one of the over 220 fixed bugs since your version fixed this problem too.

Bugs are usually only marked fixed if they have a patch attached that has been checked in. (see https://bugzilla.mozilla.org/page.cgi?id=fields.html#status). Otherwise they are resolved as WFM.

Damian Szczepanik, if you can reproduce the problem in a _current_ build (and not in an old one) you should reopen the bug. You can download a current test build from http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-trunk/ Caution: Backup your profile first or retest with a new profile.
(Reporter)

Comment 6

12 years ago
When I searched this bug, I set version=Subird 0.3a1 and author of bug 328073 set Trunk, that is newer and this is why I did not find it.
I verified this bug, because Trunk version has not this problem, so fixed.
This is duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.