prompt() no longer working

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Matti, Unassigned)

Tracking

1.8 Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0

It appears the javascript prompt() is no longer working.
When its used alone, there's no error but no prompt either.
If an alert() is put before and after, two errors are generated:

Error: [Exception... "'Permission denied to get property XULElement.accessKey' when calling method: [nsIDOMXULLabelElement::accessKey]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: http://www.matthias-keller.ch/bugzilla/prompt.html :: <TOP_LEVEL> :: line 4"  data: no]
Source File: http://www.matthias-keller.ch/bugzilla/prompt.html
Line: 4

Error: [Exception... "'Permission denied to get property XULElement.accessKey' when calling method: [nsIDOMXULLabelElement::accessKey]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: http://www.matthias-keller.ch/bugzilla/prompt.html :: <TOP_LEVEL> :: line 6"  data: no]
Source File: http://www.matthias-keller.ch/bugzilla/prompt.html
Line: 6



Reproducible: Always

Steps to Reproduce:
1. Open JavaScript console and clear it for better viewing ;)
2. Open http://www.matthias-keller.ch/bugzilla/prompt.html
3. Click away the alerts and watch the JS-Log

Actual Results:  
No JavaScript Prompt is displayed

Expected Results:  
A prompt should be displayed (works in FireFox 1.5.0.1)

Comment 1

12 years ago
I'm using Seamonkey 1.5a rv:1.9a1 build 2006032309 and I get a "wow aaa" confirm dialog and a "before" and "after" alert: the testcase works for me.

Version -> 1.8 Branch
Version: unspecified → 1.8 Branch

Comment 2

12 years ago
wfm with SeaMonkey 1.0 on Win2k

Comment 3

12 years ago
I get the JS exceptions but it still works.  The exceptions are bug 261423.

Comment 4

12 years ago
do you see this with a clean profile?
(Reporter)

Comment 5

12 years ago
Well, I recently installed Seamonkey 1.0.1 and the bug seems to have disappeared
WFM now with 1.0.1

Comment 6

12 years ago
ok, resolving WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.