Xul wizard page bleeds out of iframe

VERIFIED FIXED

Status

()

defect
P2
normal
VERIFIED FIXED
13 years ago
9 months ago

People

(Reporter: martijn.martijn, Assigned: roc)

Tracking

(Depends on 1 bug, {testcase})

Trunk
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dbaron-1.9:RsCe])

Attachments

(3 attachments)

Reporter

Description

13 years ago
See upcoming testcase.
A xul wizard page ( <wizard xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"></wizard> ) is bleeding out of the iframe where it is contained in.
That should not happen.

Doesn't happen in 2006-01-25 build, happens in 2006-01-26 build, regression from bug 317375.
Reporter

Comment 1

13 years ago
Posted file testcase
Reporter

Updated

12 years ago
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9+
Reporter

Comment 2

12 years ago
Fwiw, I just found out that this also can happen on branch builds, just not with this particular testcase.
But still, I think this should be fixed, because content in an iframe can overlay from outside its own document this way, which is bad.
Keywords: regression
Posted patch fixSplinter Review
There just isn't any code to clip IFRAMEd documents to the IFRAME!

This doesn't usually matter for HTML documents, since they usually have a root scroll frame which clips everything. But it does matter for XUL documents and I can probably come up with an HTML testcase using scrolling="no"...
Attachment #285955 - Flags: superreview?(mats.palmgren)
Attachment #285955 - Flags: review?(mats.palmgren)
Whiteboard: [needs review]
Reporter

Comment 4

12 years ago
It sounds like this also might fix bug 374327, right?
Maybe ... I'm not sure.
Whiteboard: [needs review] → [needs review][dbaron-1.9:RsCe]
Reporter

Updated

12 years ago
Blocks: 362356
Blocks: 374327
Comment on attachment 285955 [details] [diff] [review]
fix

Looks fine. It also fixes bug 374327. r+sr=mats
Attachment #285955 - Flags: superreview?(mats.palmgren)
Attachment #285955 - Flags: superreview+
Attachment #285955 - Flags: review?(mats.palmgren)
Attachment #285955 - Flags: review+
OS: Windows XP → All
Whiteboard: [needs review][dbaron-1.9:RsCe] → [dbaron-1.9:RsCe]
Attachment #288122 - Attachment is patch: true
Attachment #288122 - Attachment mime type: application/text → text/plain
checked in
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Reporter

Comment 9

12 years ago
Verified fixed, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007111905 Minefield/3.0b2pre
Status: RESOLVED → VERIFIED
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.