Mime attachment (PDF) corrupted on download

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Johny, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: version 1.5 (20051201)

Every time I download the attachment in the attached .eml message the .pdf file is corrupted, giving me a 'drawing error'.

I can get the PDF file successfully via two other methods; 

1. Using IMP against the same imap server
2. Saving the message as a .eml and opening it with Outlook Express

I suspect the problem is with the content-* headers, however, I'm no expert.

Reproducible: Always

Steps to Reproduce:
1. Double click attached pdf file in .eml file
2.
3.

Actual Results:  
PDF opens in Acrobat (v7.0.7) with an error message displayed saying 'Drawing Error', PDF is then corrupted for viewing.

Expected Results:  
Should open and render with no errors.
(Reporter)

Comment 1

12 years ago
Created attachment 216392 [details]
Contains .eml file which TB fails on, OE works with.
(Reporter)

Comment 2

12 years ago
This one seems to have been magically fixed as part of other work in TB 1.5.0.2, so I'm closing it as fixed :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 3

11 years ago
In the future, please use "WorksForMe" unless you can point to the bug with the patch that fixed the problem.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.