After javascript:document.write("helloworld"), Firefox still keeps loading something

RESOLVED DUPLICATE of bug 81980

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 81980
13 years ago
12 years ago

People

(Reporter: pbspam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

After javascript:document.write("helloworld"), the activity indicator still does something. It's a minor bug, but perhaps there's a larger problem behind it.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox.
2. type javascript:document.write("helloworld") in the location bar and press Enter.

Actual Results:  
The activity indicator still shows some loading.

Expected Results:  
The activity indicator stays still.

Comment 1

13 years ago
The document needs to be closed to stop the throbber:

javascript:document.write("helloworld");document.close();
(Reporter)

Comment 3

13 years ago
(In reply to comment #1)
> The document needs to be closed to stop the throbber:
> 
> javascript:document.write("helloworld");document.close();

Well, if it's a standard, let it be - but still, IE and Opera do not need document.close().

Another remark, not sure if it's a bug, but it isn't what I'd expect: open any webpage, after that type javascript:document.write("helloworld");document.close();. The helloworld message is displayed correctly, and there's no loading after that, but the location bar dispays the address of the previous web page.
Depends on: 326183

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 81980 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
No longer depends on: 326183
You need to log in before you can comment on or make changes to this bug.