browser history lost (deleted?) occasionally

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: me, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0

Occasionally, all the browser history gets deleted. I just open seamonkey,
and all the history is simply gone. 
It doesn't happen all the time, but it happened to me twice during the last month.

I suspect it might be related to closing the applicaiton with "Ctrl+Q" instead of clicking on the "X" button.

Reproducible: Sometimes

Steps to Reproduce:
can't always reproduce. no concrete steps....

Comment 1

13 years ago
Bookmarks and browser settings are still ok so?
(Reporter)

Comment 2

13 years ago
Yes. Passwords are also ok.
It's just the history that disappears.
(Reporter)

Comment 3

13 years ago
I should also mention that it never happened to me with the mozilla suite (before seamonkey). I had a history setting set to 900 days and for the last couple of years it worked perfectly. 
Last month it has all gone, and this month it happened again...

Comment 4

13 years ago
(In reply to comment #3)
> I should also mention that it never happened to me with the mozilla suite
> (before seamonkey). I had a history setting set to 900 days and for the last
> couple of years it worked perfectly. 
> Last month it has all gone, and this month it happened again...
> 

I'm using 90 days and sometimes get annoyed when size of history.dat in my profile is about 15MB. You are using 900 days, how big gets that? Is there enough  space on the disk to write a copy of this file, or does it exceed your quota?

Comment 5

13 years ago
Could this have happened after deleting an entry from the history autocomplete popup (see bug 242207 comment #51)?
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> Could this have happened after deleting an entry from the history autocomplete
> popup (see bug 242207 comment #51)?

Never used this feature, so it's probably not directly related to this bug.
The address bar completions are gone too, but the favourites are untouched.

(In reply to comment #4)
> I'm using 90 days and sometimes get annoyed when size of history.dat in my
> profile is about 15MB. You are using 900 days, how big gets that? Is there
> enough  space on the disk to write a copy of this file, or does it exceed your
> quota?

This is a windows machine used by me only, so quota is not an issue. Also
I've lost it several times now, so for the other times it was much smaller (approx 30 days).
Can't tell how large it gets since it's gone now. I remember backing up my profile with the history in place and it wasn't extremely huge (~40mb?).

Comment 7

12 years ago
This may be an instance of longstanding (like, four years!)
bug 63292.

xanthian.

Comment 8

12 years ago
When I started up Mozilla today (2-20-07), at the New Release opening page (the new Home Page), I clicked on the History link and discovered that ALL of my History URLs previously listed had disappeared. Why did that happen and how do I recover it?

Comment 9

12 years ago
(In reply to comment #8)
> When I started up Mozilla today (2-20-07), at the New Release opening page (the
> new Home Page), I clicked on the History link and discovered that ALL of my
> History URLs previously listed had disappeared. Why did that happen and how do
> I recover it?

Questions like these are better asked in the mozillazine forums
http://forums.mozillazine.org/index.php?c=3

SeaMonkey Support
User Help for Seamonkey and Mozilla 1.x Suite
(Anonymous/guest posting allowed)
http://forums.mozillazine.org/viewforum.php?f=40

It's better if you register and ask in SeaMonkey General or SeaMonkey Bugs, you don't get spam on your address registerd over there. (You get it here.)


To your question:

Look for history.dat in your profile.
As I rarely use history manually, I don't notice when it is gone. I delete it when  I'm scarce on drive space.
I'm using current nightlies and sometimes tinderbox builds for years now, and rarely had accidents. 
I would recommend to you creating a new profile, and not using the 'Default User'. 
Reason: A profile can get corrupted.
When the browser closes, bookmarks, history ans browser layout are written back to the profile. If your browser crashes, and or the OS crashes, and that stuff is written partially only, yout profile could be corrupted. I've got the impression, if your profile is corrupted, it isn't used, but the browser switches automatically to the 'Default User' profile. If this profile is corrupt, it is restored to factory condition, i.e. all own bookmarks lost, only the default mozilla bookmarks available.

BTW: I didn't see a new release, so I suppose you are using nightlies, but I still don't know if these are of the current Branch type 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.2pre) Gecko/20070222 SeaMonkey/1.1.1

or of Trunk. Trunk is fine if you want a look into what will be comming, but you shouldn't rely on never having problems. BTW: I never lost my mail using mozilla trunk nightlies and seamonkey branch when trunk stopped working on win98. I'm using the mozilla suite client for more than 5 years with minor problems only.

Comment 10

11 years ago
I have noticed that with the current nightly, I lose the navigation history.

[Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007080305 Minefield/3.0a7pre]

Steps to reproduce (for my case):
1. enter www.mozilla.org in the address bar
2. press enter
3. select the Developers tab on the page
      OBSERVATION: There is no backward navigation generated.
4. navigate some more to different pages
      OBSERVATION: There is no backward navigation generated.

Comment 11

11 years ago
reporter "I haven't seen this problem in the last 6 months. I now use SeaMonkey 1.1.4"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.