Mouse double click event (nsIDOMMouseListener::MouseDblClick) not called

VERIFIED DUPLICATE of bug 29473

Status

()

P3
major
VERIFIED DUPLICATE of bug 29473
19 years ago
19 years ago

People

(Reporter: cmanske, Assigned: joki)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
In Composer, we implement a class nsTextEditorMouseListener derived from
nsIDOMMouseListener, but MouseDblClick() is not getting called. All the other
mouse event handlers are called ok. I also checked other classes such as
nsGfxListEventListener::MouseDblClick and nsMenuListener::MouseDblClick
and they don't get called either.
This is blocking editor work as we need to implement our double-click support
before Beta2.
(Reporter)

Updated

19 years ago
Whiteboard: [blocker for Composer]
(Assignee)

Comment 1

19 years ago
Yes, we need to implement dblclick but its only for 4.x compatibility, this 
isn't a blocker.  Read the spec, the current way to do dblclick is to use 
mousedown/click/mouseup (whichever applies) and check the clickCount property
Status: NEW → ASSIGNED
Whiteboard: [blocker for Composer]
Target Milestone: --- → M18
(Reporter)

Comment 2

19 years ago
Cool. I wasn't aware that I should monitor MouseUp instead. So I'm happy now!
(Assignee)

Comment 5

19 years ago
Duping on 29473

*** This bug has been marked as a duplicate of 29473 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 6

19 years ago
verified duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.