Status

Thunderbird
Mail Window Front End
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Gyula Zsigri, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

3.88 KB, text/plain
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7

RTF attachments received from Eudora are displayed inline. You can right-click on the attachment in the attachment pane and save it but the RTF code displayed in the message window is annoying.

No such problem with RTF attachments received from Outlook Express or The Bat.

Reproducible: Always

Steps to Reproduce:
1. Ask a Eudora user to send an RTF attachment to you.
2. Open the message in Thunderbird.

Actual Results:  
RTF code displayed inline.

Expected Results:  
RTF code not displayed inline.

Comment 1

12 years ago
This behavior depends on the MIME type that Eudora provides when it sends an 
RTF attachment.  "text/rtf" is the MIME type used by Outlook, and that type is deliberately not displayed inline.  What type does Eudora use?  (See this by
selecting  View|Source  on the message, scrolling down to where the attachment is in the file, and reading the Content-Type header for that section.)
(Reporter)

Comment 2

12 years ago
Eudora uses text/plain, which is wrong IMHO, nevertheless Outlook Express handles it properly via the Content-Disposition statement, which identifies the RTF file as an attachment:

Content-Type: text/plain; charset="us-ascii"
Content-Disposition: attachment; filename="eudora2tb.rtf"

(Reporter)

Comment 3

12 years ago
Created attachment 216571 [details]
eudora2tb.eml

sample rtf attachment from Eudora
(Reporter)

Comment 4

12 years ago
Created attachment 216573 [details]
eudora2tb.eml

sample attachment from Eudora
Attachment #216571 - Attachment is obsolete: true
(Reporter)

Comment 5

12 years ago
Could you remove the first attachment, please? It contains some personal data. Sorry for the inconvenience.

Comment 6

12 years ago
(In reply to comment #2)
> Eudora uses text/plain, which is wrong IMHO, nevertheless Outlook Express
> handles it properly via the Content-Disposition statement, which identifies the
> RTF file as an attachment:
> 
> Content-Type: text/plain; charset="us-ascii"
> Content-Disposition: attachment; filename="eudora2tb.rtf"
> 

Thunderbird actually does it correctly, Outlook Express not : the MIME-type should be have preference over the file-extension. The same difference exists in Firefox & Internet Explorer. See bug 108186 for an explanation. See also bug 155537.

Comment 7

12 years ago
Comment on attachment 216571 [details]
eudora2tb.eml

(deleted)

Comment 8

12 years ago
Agreed; the problem is with Eudora, not with Thunderbird.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

12 years ago
(In reply to comment #7)
> (From update of attachment 216571 [details] [edit])
> (deleted)

It is still there.
(Reporter)

Comment 10

12 years ago
(In reply to comment #6)
> Thunderbird actually does it correctly, Outlook Express not : the MIME-type
> should be have preference over the file-extension. The same difference exists
> in Firefox & Internet Explorer.

This is not a case of MIME type vs. file extension. This is Content-Type vs. Content-Disposition. If Content-Disposition specifies an attachment (no matter whether its file extension is rtf, txt, or whatever) then the attachment should be treated as an attachment, IMHO. It would do no harm and would not be as annoying as viewing RTF code.

Yes, Eudora is buggy but unfortunately the Eudora users I know claim that Thunderbird is the only email client that does not handle their rtf attachments properly. Actually, they are wrong because The Bat treats Eudora attachments like Thunderbird does but they just don't care about The Bat (or Thunderbird).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 11

12 years ago
(In reply to comment #10)
> This is not a case of MIME type vs. file extension. This is Content-Type vs.
> Content-Disposition. If Content-Disposition specifies an attachment (no matter
> whether its file extension is rtf, txt, or whatever) then the attachment should
> be treated as an attachment, IMHO. It would do no harm and would not be as
> annoying as viewing RTF code.

Then how will Thunderbird know that it's a RTF file ? That's not stated in Content-Disposition (which contains the filename), but in Content-Type (which contains the MIME-type). Here, the type is set to text/plain, so it is treated as a text/plain attachment. It should be text/rtf.
(Reporter)

Comment 12

12 years ago
(In reply to comment #11)
I see. Some attachments, including plain text or html files, are both displayed in the message window and listed in the attachment pane. Then this is where exceptional treatment could increase user happiness. I agree that file extensions should normally be ignored, since they are not universal, *BUT* if an allegedly plain text file has an .rtf extension then it should only be listed in the attachment pane and not displayed in the message window. This would only make users unhappy in the unlikely event when they receive a real plain text file whose name ends in .rtf for some weird reason. 

Comment 13

12 years ago
This bug is Invalid, however much you disagree.  Outlook is *not* the paradigm of a mail program, and Thunderbird does not have to do things the way Outlook does all the time.  It's a waste of development efforts to try to account for the bugs in all the other mail software that's out there.

Are you even sure that the problem is with Eudora itself, rather than that user's particular configuration?  It's quite possible to configure TB to send 
.RTF files as text/plain, text/rtf, or any other type.
(Reporter)

Comment 14

12 years ago
(In reply to comment #13)
> It's a waste of development efforts to try to account for
> the bugs in all the other mail software that's out there.

OK, I accept that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.