<selects> become detatched if window is scrolled with arrow keys

VERIFIED DUPLICATE of bug 27661

Status

()

P3
major
VERIFIED DUPLICATE of bug 27661
19 years ago
18 years ago

People

(Reporter: kennedyh, Assigned: rods)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; N; SunOS 5.6 sun4u; en-US) Mozilla/m14
BuildID:    2000030317

When viewing any form with a <select> on a page that is large
enough to scroll with the <up>/<down> arrow keys, if you click on
the select and then attempt to walk down the options list using
the arrow keys (as you can in NN or IE), you get an unexpected behavior.

instead of walking the options list, M14 on WinNT and Solaris 2.6
both detatch the drop down, and scroll the screen instead, with the
dropdown in the same position it was initally, effectively floating
over the scrolling page.


Reproducible: Always
Steps to Reproduce:
1. pull down a <select> drop down
2. attempt to walk down list with arrow keys
3. gasp in horror as page scrolls, and select box stays put.


Actual Results:  the page scrolled, the dropped-down select box stayed at the
same x:y coordinates on the screen that it had started at.


Expected Results:  Behaved like any dropdown on any planet, walked down the list
when the arrow keys were used.

Comment 1

19 years ago
Still a problem as of Linux build 2000032309.

Comment 2

19 years ago
I see this on Debian Linux/PowerPC (potato) too.

Yuck. confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

19 years ago
mass-move to M16
Target Milestone: --- → M16
(Reporter)

Comment 4

19 years ago
heheh.
this gets even better..

on win32, opening a <select> for scrolling, then moving up or down the menu
with the mouse (but not selecting anything), then alt-tab-ing between windows,
the now-opened <select> will follow you between windows as a phantom select box.

its still communicating with mozilla however, because if you do select
something, say while you have the phantom select over your ssh window, the
browser window you originally opened the select in will act on your selection.

Comment 5

19 years ago
This is a DUP of bug 27661, "[GFX LIST]navigating in combo/list box causes 
entire page to scroll", ASSIGNED, M16.

*** This bug has been marked as a duplicate of 27661 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

19 years ago
*** Bug 37497 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.