Moving profile folder causes toolbar icon display to fail

VERIFIED INCOMPLETE

Status

()

Firefox
General
VERIFIED INCOMPLETE
12 years ago
7 years ago

People

(Reporter: Fox2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Clean install, moved profile folder and edited profiles.ini

On restart, icons in all toolbars fail to be displayed.

Not helped by restarting in safe mode, which makes it look like a path bug in toolbar display.

Reproducible: Always

Steps to Reproduce:
Reproduction steps:
1. Clean install FF latest (1.5.0.1)
2. Install some extensions (All-in-one sidebar was one, may be an unnecessary step for replication?)
3. Close FF
4. Move profile.xxxxxxxx folder contents elsewhere and edit profiles.ini as described to point to the new folder (using native windows "\" not "/" for path)
5. Restart FF
6. Profiles folder is found, but icons on sidebar and toolbars etc are not displayed. Toolbars now display text only for buttons.
(Reporter)

Comment 1

12 years ago
The buttons themselves, and toolbar hover tips, work. Just the icons are not being displayed.
Maybe you could try deleting everything in your profile except for the important files like bookmarks.html, prefs.js, user.js, cookies.txt,
history.dat, hostperm.1, signons.txt, key3.db and the folders chrome and extensions.
(Reporter)

Comment 3

12 years ago
Yup, deleting all the rest and letting FF recreate it, is a workaround.
(Reporter)

Comment 4

12 years ago
Darn, I was wrong

Closed FF and reopenned it later and the icons have vanished again.
(Reporter)

Comment 5

12 years ago
Okay, I don't know what's up.

FF has lost its toolbar icons again, following a restart.
I've never seen this. Please try making a new profile (rename the folder Mozilla in Application Data) and copy the files from comment 2 to the new profile.
Or maybe one of the extensions is not compatible and messing it up?

Comment 8

12 years ago
You're not supposed to be able to move the profile like that. There are bugs about it.
(Reporter)

Comment 9

12 years ago
Hmm..... "not supposed to"?

This link:  http://www.mozilla.org/support/firefox/profile#move
thinks otherwise. 

Which is important to me as I run Firefox off a mobile device on different systems, and don't want to accidentally leave any personal web stuff from my profile folder (history, personal sites, etc) on odd machines if I get forgetful or someone else gets inquisitive.

http://kb.mozillazine.org/Thunderbird_:_FAQs_:_Changing_Profile_Folder_Location#Troubleshooting
says the same, but gives some fixes that I hadn't seen, that sound likely to work.

This probably needs clarifying, or fixing, or both.

Comment 10

12 years ago
Point was, there are files that still have absolute paths in them. It's not as bad as it used be, but still. If I wrote those docs, I wouldn't suggest moving profile like that.
(Reporter)

Comment 11

12 years ago
Are these absolute references in extensions, core, or both?

Comment 12

12 years ago
Actually it currently appears to only be in secmod.db and a bunch of regenerated files now, so I guess I was wrong (the other references to the full path in my profile are leftovers from older versions I guess). So "core" is relatively clean in this regard.

It would be strange that an extension causes images to disappear though.

Comment 13

12 years ago
What disappears is just the All-in-one Sidebar icon bar. Cause are the absolute path references in extensions.ini. Deleting that file and restarting should take care of the issue. Otherwise you'll see "No chrome package registered for ..." messages in the console for all extensions installed into the profile (and all those extensions will stop working).
(Reporter)

Comment 14

12 years ago
(In reply to comment #13)
> What disappears is just the All-in-one Sidebar icon bar. Cause are the absolute
> path references in extensions.ini. Deleting that file and restarting should
> take care of the issue. Otherwise you'll see "No chrome package registered for
> ..." messages in the console for all extensions installed into the profile (and
> all those extensions will stop working).

Incorrect. As stated originally, "icons in all toolbars fail to be displayed." I've never seen the message referred to above.
(Reporter)

Comment 15

12 years ago
(In reply to comment #13)
> What disappears is just the All-in-one Sidebar icon bar. Cause are the absolute
> path references in extensions.ini. Deleting that file and restarting should
> take care of the issue. Otherwise you'll see "No chrome package registered for
> ..." messages in the console for all extensions installed into the profile (and
> all those extensions will stop working).

Just checked extensions.ini. All extensions in that file do reference the correct drive and path. The fault may be elsewhere, or alternatively with some extension I've since disabled or uninstalled (if disabled extensions are removed from extensions.ini)

secmod.db confirmed, contains:  

ModuleTconfigdir='C:\\Documents and Settings\\Administrator\\Application Data\\Mozilla\\Firefox\\Profiles\\qphtpw30.default'

Comment 16

12 years ago
(In reply to comment #14)
> Incorrect. As stated originally, "icons in all toolbars fail to be displayed."
> I've never seen the message referred to above.

Can you actually reproduce this behavior without installing any extensions? You seemed not to be sure about that in your "Steps to Reproduce" - this might however make a difference.

And just to make sure: are you using the default theme or a separately installed one?

To see the message(s) I mentioned, you'll have to set the pref javascript.options.showInConsole to true (in about:config).

(And resetting the severity to "normal" since moving profiles around isn't really a "major" feature.)
Severity: major → normal
(Reporter)

Comment 17

12 years ago
I've reinstalled, will see if that fixes it. 

Part of the problem is that moving the profile folder with extensions already installed may cause problems that weren't hinted at in the Wiki. Perhaps that's a bug of its own. Either way I suggest let's see if this time around, it has any issues.

Comment 18

11 years ago
Does this issue still persist? Any answers to the questions from comment #16?
Whiteboard: CLOSEME 08/19

Comment 19

11 years ago
Reporter: If you still see this issue, please reopen this bug and answer the questions from comment #16.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE
Whiteboard: CLOSEME 08/19

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.