Drop Down List For Column Header Selection Missing

VERIFIED DUPLICATE of bug 33524

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED DUPLICATE of bug 33524
19 years ago
14 years ago

People

(Reporter: jay garcia, Assigned: David Hyatt)

Tracking

Trunk
Future
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][6/15])

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; Win98; en-US; m14)
BuildID:    32409

The drop down list of column headers is missing

Reproducible: Always
Steps to Reproduce:
1.Open Mail-News
2.Look for column header drop down list for choices
3.


Actual Results:  Drop down list missing

Expected Results:  Not missing

Comment 1

19 years ago
Are you talking about a menu item?  I'm not sure what you are referring to.  Thanks.
(Reporter)

Comment 2

19 years ago
I'm talking about the column headers, ie., Subject, Unread, Status, etc and the 
drop down list that used to be on the right side of the header column such that 
when you clicked on the arrow it would present you with a list of header choices 
that could be selected/unselected to appear as column headers.
(Reporter)

Comment 3

19 years ago
What progress is being made here. Still a problem in latest build 3/28/00

Comment 4

19 years ago
The column headers drop-down is back in 4/27 build.  Can you check, Jay, to make 
sure we are talking about the same thing?

We had some bugs before with this control missing.
Assignee: selmer → putterman
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

19 years ago
When first accessed, the column headers selection context is there. However, 
click on the arrow, unselect any item after which the arrow disappears and you 
cannot access the menu again. This has been happening for the last dozen or so 
builds including today's.

Comment 6

19 years ago
reassigning to hyatt. I think this is a tree bug.
Assignee: putterman → hyatt
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M21

Comment 7

18 years ago
Mass-moving all M20-M30 bugs to Future.
Target Milestone: M21 → Future

Comment 8

18 years ago
Peter - does this mean it won't be fixed for Netscape 6?
The reason I'm asking is that if the drop-down list won't behave correctly, then
we should remove it completely and not allow people to designate which column
headers in mail's thread pane can be displayed or not.

As of 5/25 build, the description by Jay still holds true.  You can get the
popup to show up and specify which columns to hide, but you can never bring that
popup back up again even after a restart of the application.

Comment 9

18 years ago
forgot to cc: peter last time.  Peter, pls see my previous comments/question.
Thanks.

Comment 10

18 years ago
I can't assign any work that the PDT hasn't approved.  If you want this 
work done, please nominate it appropriately.

Comment 11

18 years ago
nominating nsbeta2.  Mail needs the ability to add and remove columns.  If it 
doesn't get nsbeta2 approval, can we put it on the radar for nsbeta3?  If this 
is really a futured bug then we need to remove the column chooser from mail.  
One way or another we need a bug approved.

On the other hand, I'm not convinced this is hyatt's bug.  The thread pane 
column picker started behaving weird the day we made a bunch of skin changes to 
the mail window.  cc'ing hangas.  We might have some xul/css bug.
Keywords: nsbeta2

Comment 12

18 years ago
Looks like a dup of bug 33524 which is [nsbeta2+][6/15] so I'll do the same with 
this.
Whiteboard: [nsbeta2+][6/15]

Updated

18 years ago
QA Contact: lchiang → nbaca

Comment 13

18 years ago
resolving this as a dup of the later bug, because it is more general purpose, 
and the drop-down list wasn't the intended UI anyway.

*** This bug has been marked as a duplicate of 33524 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

18 years ago
QA Contact: nbaca → pratikd

Comment 14

18 years ago
Using Build 2000-06-20-08 M17 on MAC, Linux, and NT4
Verified: DUPLICATE

Note: Problem mentioned in this bug seems to be fixed. 

Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.