All users were logged out of Bugzilla on October 13th, 2018

Mozilla doesn't use locale config when setting default paper size

RESOLVED DUPLICATE of bug 144625

Status

()

--
major
RESOLVED DUPLICATE of bug 144625
13 years ago
13 years ago

People

(Reporter: elijah, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060130 Red Hat/1.7.12-1.4.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050702

[removing old profile]

gamma09:elijah:[~/tarprogs/mozilla]$ setenv LC_PAPER sv_SE.ISO8859-15
gamma09:elijah:[~/tarprogs/mozilla]$ ./mozilla
gamma09:elijah:[~/tarprogs/mozilla]$

In printer properties paper size is set to "letter" but the correct size for the
Swedish locale is "A4".

Also happens in Firefox 1.5.0.1, US, UK and Swedish versions.



Reproducible: Always

Steps to Reproduce:
Start mozilla with no profile, it will not set default paper size according to locale environment variables.



Expected Results:  
Mozilla/Firefox should look for default paper size in locale environment variables. 

This causes a lot of problems for print server admins...
*** Bug 332219 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 144625 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.