Shouldn't allow deleting special folders when Account Setting setup special folders on server

RESOLVED WORKSFORME

Status

MailNews Core
Backend
P3
normal
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: jefft, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
We shouldn't allow users to deleter special folders, such as Inbox, Trash, 
Drafts .... etc.
(Reporter)

Comment 1

18 years ago
To me...
Assignee: selmer → jefft
Target Milestone: --- → M15
(Reporter)

Comment 2

18 years ago
The menu should be dimmed out if it's a special folder. Rename should do the 
same.
Status: NEW → ASSIGNED

Comment 3

18 years ago
Adding jglick to the Cc: list. 

According to Main Mail spec 
(http://gooey/client/5.0/specs/mail/messenger/messenger.html), the only folder 
that you cannot delete is the Inbox folder. I've copied some of its contents 
here:

"Folders - Deleting

Any folder created by the user can be deleted. 

The user can not delete an Inbox. 

Special Folders (Sent, Trash, Drafts) and default Local Folders (Unsent 
Messages, Stationery, Trash) can be deleted, but are recreated
automatically as necessary (For example, the user deletes the Trash and then 
throws something out, the Trash Folder will automatically appear
(IMAP model excepted). 

When attempting to delete a folder, the user gets a confirmation dialog, "Are 
you sure you want to delete folder <name> and all it's contents?". "

Comment 4

18 years ago
*** Bug 33764 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
QA-me
QA Contact: lchiang → huang

Comment 6

18 years ago
What is in the spec that nbaca refers to was agreed upon at an issues meeting 
(way back when!). Users should be able to delete special folders if they don't 
use them, such as Drafts and Templates.  They would be re created as necessary.

The Inbox is the only exception.
(Reporter)

Comment 7

18 years ago
This is fixed. Users cannot delete Inbox and Trash. The others are allowed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
Isn't Trash folder allowed to delete?
(Reporter)

Comment 9

18 years ago
This is a chicken and egg problem.

Comment 10

18 years ago
What if an IMAP user is using the Trash model and then switches to the IMAP 
delete model.  They should be allowed to delete their Trash folder.
(Reporter)

Comment 11

18 years ago
True.
(Reporter)

Comment 12

18 years ago
On the other hand, we shouldn't confused with the message delete model with the 
folder delete. The Imap delete model, move deleted message to the Trash folder 
or remove immediately should only apply to messages only. I don't want to have 
the user having the impression that he can choose whether to move deleted folder 
to the Trash folder, mark folder as deleted or remove the folder immediately. 
jglick do we have a design for this or it is vague at the moment?

Comment 13

18 years ago
I did notice if my trash folder is empty & I selected "Mark it as deleted" or 
"Removed it immediately" from Mail server properties from IMAP of the 
preferences. The Trash folder will disappear!!

Comment 14

18 years ago
And it occurs on 4.7.....

Comment 15

18 years ago
Oh! Even the Trash folder is not empty, Trash folder will disappear when I 
select "Mark it as deleted" or "Removed it immediately" from Mail Server of 
Preferences....
(Reporter)

Comment 16

18 years ago
Isn't that confusing? At least to me.
(Reporter)

Comment 17

18 years ago
Reopen this for the imap case ....
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 18

18 years ago
>Oh! Even the Trash folder is not empty, Trash folder will disappear when I 
>select "Mark it as deleted" or "Removed it immediately" from Mail Server of 
>Preferences....

It doesn't get deleted, it just moves! (on my 4.x system) Trash folder is moved 
out of the special folders area and into the alphabetical listing of regular 
folders.

>On the other hand, we shouldn't confused with the message delete model with the 
>folder delete. The Imap delete model, move deleted message to the Trash folder 
>or remove immediately should only apply to messages only. I don't want to have 
>the user having the impression that he can choose whether to move deleted 
>folder 
>to the Trash folder, mark folder as deleted or remove the folder immediately. 

I agree.
So how about if the user has POP or IMAP, move to Trash model, the Trash folder 
can not be deleted.

If the user has IMAP move to Trash model (and has stuff in the Trash) and then 
switches to one of the other two models, the Trash folder is moved out of the 
special folders area into the alphabetical list of regular folders and can now 
be deleted?

If the user has IMAP move to Trash model (and nothing in their Trash) and then 
switches to one of the other two models, the Trash folder is removed?

Comment 19

18 years ago
Mass moving to M16 to get these off the M15 radar.  Please let me know if this
is really an M15 stopper.
Target Milestone: M15 → M16

Comment 20

18 years ago
Yes. Trash folder will depend on how you setup the deleted message modes from 
the server's preferences to perform different behaviors.

I found that even nothing in Trash folder and then 
switched from Trash mode to the other two modes, the Trash folder still in the 
alphabetical list of regular folders and can be deleted 
(it's not removed automatically)

So, Once the deleted messages in the Trash mode, "Deleted Folder" menu will be 
grey out and won't allow to delete Trash folder.

If change the mode from Trash mode (no matter it's empty or not)to other two 
modes, trash folder become the normal folder and "Deleted Folder" menu will be 
available for delete trash folder...

Comment 21

18 years ago
And I found that the draft & template deletion are also depend on how you setup 
the Copies & Folder from server or local from the preference, too.

Once the Copies & Folder set draft & template on server, "Deleted Folder" menu 
will be grey out and won't allow to delete those folder.

If change Copies & Folder from server to local, draft & template folders become 
the normal folder and "Deleted Folder" menu will be available for delete draft & 
template folders.

For Sent folders, no matter you set to server or local, it always allow to 
delete Sent folder.....

Above is the investigation from 4.x, I don't know whether we will have any new 
design for Netscape6 or not?!

Comment 22

18 years ago
What you just described sounds right.

Comment 23

18 years ago
Not beta2 stopper, marking M18.  Please add beta2 keyword if you disagree.
Target Milestone: M16 → M18

Comment 24

18 years ago
Nominating for nsbeta3 and "correctness."
Keywords: correctness, nsbeta3

Comment 25

18 years ago
*** Bug 46634 has been marked as a duplicate of this bug. ***

Comment 26

18 years ago
Since bug 46634 has been marked as duplicate of this bug.
Would like to remind developers to display a warning message before deleting the 
Sent folder as bug 46634 described.

Comment 27

18 years ago
Win32 2000-07-31-05-m17 beta2 build.  Delete is disabled (incl. del key) if 
focus is on the Inbox or Trash folder.  Delete is enabled for all other folders.  
I think this is working ok now.  The remainder of the bug is to probably give 
the warning for the Sent folder as per bug marked duplicate.

Comment 28

18 years ago
Since 
1)Trash folder will depend on how you setup the deleted message modes from 
the server's preferences to perform different behaviors.
2)Draft & Template deletion are also depend on how you setup 
the Copies & Folder from server or local from the preferences

I need to run more test scenarios to ensure the remainder of this bug is the 
warning for the Sent folder....

Updated

18 years ago
Keywords: mail2

Updated

18 years ago
Whiteboard: [b3 need info]

Comment 29

18 years ago
After run some more test scenarios, I still need to keep this bug open since:

1) Delete folder menu should be disable/grey out for all the special folders 
(except Sent folder)when account settings setup sepcial folder on the SERVER. 
(This bug only fix for Inbox and Trash, still didn't fix for Draft & Template)

2) Since delet folder menu is available when draft & template set to local and 
fall in to the "regular" folder hierarchy. So the other reminder issues will be:
 a. Warning for the Sent folder delection.
 b. bug 39121 - change to Remove Immediately should unspecialize Trash folder     
and also allow to be deleted (which already addressed to future bug)

So, based on 1): didn't fix for Draft & Template, I am still keeping this 
bug open.
   


Summary: Shouldn't allow deleting special folders → Shouldn't allow deleting special folders when Account Setting setup special folders on server
Whiteboard: [b3 need info]

Comment 30

18 years ago
For now, we should treat the Sent folder the same as the other.  We're afeared 
that bad things would happen if you deleted the Sent folder...
Whiteboard: [nsbeta3+]

Comment 31

18 years ago
No, nothing bad should happen since I spent the weekend making it so that we
would recreate special folders if they don't exist (even though that bug was
nsbeta3-minused :-) )

Comment 32

18 years ago
Yes. for Sent folders, no matter you set to server or local, it always allow to 
delete Sent folder.....we probably only need to consider to display a warning 
message before deleting the Sent folder as bug 46634 described.

Comment 33

18 years ago
clearing nsbeta3+ for reconsideration. We already prompt for confirmation when
deleting a folder, so I think an extra warning is not critical.
Whiteboard: [nsbeta3+]

Comment 34

18 years ago
> 1) Delete folder menu should be disable/grey out for all the special folders 
>(except Sent folder)when account settings setup sepcial folder on the SERVER. 
>(This bug only fix for Inbox and Trash, still didn't fix for Draft & Template)

There are some other issues left, it's not only prompt confirmation when 
deleting a folder. I still can delete draft & template folders which is not 
correct. I will suggest this bug keep nsbeta3+


Comment 35

18 years ago
I'm not saying it's correct. I'm just saying that the fact that we DID ask for
confirmation, and that we WILL recreate the folder next time you try to save a
draft or template means this probably shouldn't be an nsbeta3+ bug.

Comment 36

18 years ago
> we WILL recreate the folder next time you try to save a draft or template 

I did try. With copies and folder setup on the SERVER -- When I tried to send 
the new message for save as draft/template, Nothing happened, Seamonkey couldn't 
create the draft and template folders unless users create the template & draft 
folders manually. Does seamonkey suppose to work this way? 

Comment 37

18 years ago
No, it should create the sent folder when you send, the drafts folder when you
save a draft, and the template folder when you save as template. It worked last
time I tried it.

Comment 38

18 years ago
I verify that David fix bug 25146 for migrated profile.
Bug 50211 logged for address above problems for NEW profile, if this will be 
nsbeta3-, then bug 50211 probably will be nsbeta3+.....

Comment 39

18 years ago
marking nsbeta3- per mail triage.
Whiteboard: [nsbeta3-]

Comment 40

18 years ago
sorry for the extra email. Removing mail2 keyword.
Keywords: mail2

Comment 41

18 years ago
reassigning jefft's bugs to naving
Assignee: jefft → naving
Status: REOPENED → NEW

Updated

17 years ago
Keywords: mail3

Comment 42

17 years ago
marking nsbeta1-. It looks like we are handling the important cases.
Keywords: nsbeta1-

Updated

17 years ago
Target Milestone: M18 → ---

Comment 43

17 years ago
*** Bug 67928 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 44

17 years ago
We don't allow special folders deletion. marking wfm.
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 45

17 years ago
Reopening this bug since "Delet Folder" menu should be disabled when 
draft/template are set up on the server, BUT it is still enable.....

Test scenarios should be covered from this bug as following:
* "Delete Folder" menu should be grey out/disabled:
  -Inbox 
  -Trash Folder(for move to trash mode)
  -Draft/Template folder setup on the SERVER

* "Delete Folder" menu should be enabled:
  -Trash Folder (for mark as deleted & delet immediately modes)
  -Draft/Draft/Template folder setup on LOCAL
  -Sent Folder for both setup on SERVER & LOCAL


Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 46

16 years ago
*** Bug 105996 has been marked as a duplicate of this bug. ***

Comment 47

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020419

I did the following test:

1) In my POP3 account the Drafts folder is Drafts, the folders Templates and
Sent are set to use Trash.

2) I deleted Drafts, Templates and Sent

3) I restarted Mozilla

4) All three are newly created

Expected result:
a) Don't allow Drafts to be deleted
b) Don't recreaste Templates and Sent (bug 105996 duped to this one)

pi

Comment 48

16 years ago
*** Bug 147591 has been marked as a duplicate of this bug. ***

Comment 49

16 years ago
I find the "back then" spec clear and logical (comment #3)

In 1.0 I can delete special folders using the toolbar button, but the option is
not present on the contextual menu. Stil, it's good enough for me.

Thanks.

Comment 50

16 years ago
Mozilla v1.0 re-creates the folders at start-up if they were deleted.
Can this be an option? Can it be disable via some .js file? 

Is anyone looking at this bug?

Comment 51

16 years ago
This is not Windows only, changing.

Using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/2002101815 (+
patches 101274, 101762, 103210) I have the following: I cannot delete any of
those folders: Inbox, Unsent Messages, Drafts, Templates, Trash, Sent. So in a
sense this WFM. *But* most of these folders are just a PITA. I have set other
folders to take their functions (I don't use Unsent, Templates, Sent). Since
this problem was duped here (e.g., bug 105996), this does not WFM. A special
folder should be undeletable iff it is used as such.

Actually, Unsent Messages was just newly created for me after seveal months of
silence:-(

pi
OS: Windows NT → All
Hardware: PC → All
Depends on: 197228
Filed bug 197228 for a sequence demonstrating the sort of stuff mentioned in
comment 47 and comment 51 -- looks like the logic is right but the pref isn't
quite sticking right?

Comment 53

15 years ago
What this bug originally asked for works for quite some time. Since we now have
bug 197228 which clearly states the problem with non-deletable folders, I close
this bug.

Bug 105996 would be a dupe of the new bug, not this one, but never mind.

pi
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
No longer depends on: 197228
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.