uninstaller does not work (does not delete GRE & SeaMonkey directory)

VERIFIED FIXED

Status

SeaMonkey
Installer
--
major
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: baffclan, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Dependency tree / graph
Bug Flags:
blocking-seamonkey2.0a1 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060330 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060330 SeaMonkey/1.5a

uninstaller dose not work (does not delete SeaMonkey.exe)

Reproducible: Always

Steps to Reproduce:
1. inttall trunk seamonkey-1.5a.en-US.win32.installer.exe
   (from /pub/mozilla.org/seamonkey/nightly/2006-03-30-11-trunk/)
2. uninstall seamonkey


Actual Results:  
uninstaller dose not work.
seamonkey.exe is found in installed folder.

Comment 1

12 years ago
Was this behaviour also present in older trunk builds or SeaMonkey 1.0?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Was this behaviour also present in older trunk builds or SeaMonkey 1.0?
I used trunk build.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060330 SeaMonkey/1.5a
(Reporter)

Comment 3

12 years ago
(In reply to comment #0)
> 2. uninstall seamonkey

2. uninstall seamonkey without plugins folder

Comment 4

12 years ago
confirming Mozilla/5.0 (Windows; U; Windows98; en-US; rv:1.9a1) Gecko/20060330 SeaMonkey/1.5a

First time I did a clean install, creating new directories for GRE and Seamonkey, then after deinstallation I just deleted the remaining folders

Installing is o.k., browser is launched at end of installation. Installed without Quickstart.
Deinstalling just deletes the folders in GRE and Seamonkey which are holdung the uninstall programs and data, then alerts that the directory seamonkey wasn't deleted because not all files in it had been removed, delete directory Y/N? 

Depending on the answer the seamonkey directory is deleted or not, the GRE directory always stays, but it's deinstaller directory was deleted, and then before closing down the Seamonkey entry from Add/Remove Programms is deleted.

To be sure nothing was running I installed, rebooted and deinstalled, same behaviour.

I don't havbe a clue when this regressed,
baffclan, which version did you have before, and was it uninstalling cleanly?

maybe related: 
Bug 325042 Feedback survey prevents uninstaller from completing
Another installer bug:
Bug 330885 uninstaller hangs waiting for parent process to disappear
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: uninstaller dose not work (does not delete SeaMonkey.exe) → uninstaller does not work (does not delete SeaMonkey.exe)
Version: unspecified → Trunk

Comment 5

12 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060324 SeaMonkey/1.5a
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060324 SeaMonkey/1.5a

so regressed somewhere between 2006032409 and 2006033009
Summary: uninstaller does not work (does not delete SeaMonkey.exe) → uninstaller does not work (does not delete GRE & SeaMonkey directory)

Comment 6

12 years ago
timeframe for regression:
1.9a1: 2006032709 ok
1.9a1: 2006032809 broken
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=20060327+07%3A00&maxdate=20060328+09%3A00&cvsroot=%2Fcvsroot

GRE only directories 'Setup GRE' and 'uninstall' are uninstalled,
in Seamonkey directory only 'uninstall' is uninstalled, then an Alert tells that not all files were deleted, and asks for deleting the directory.
After giving the answer (Y deletes the directory) the Add/RemoveProgram entry is removed. Seamonkey can still be started via seamonkey.exe and runs perfectly, but can't be deinstalled.
Severity: normal → major
(Reporter)

Updated

12 years ago
Duplicate of this bug: 363424

Comment 8

11 years ago
When I uninstall SeaMonkey 1.5, I notice that the Start menu entries are not removed.  I didn't see that symptom mentioned here.  Is this the same bug, or should I open a new one?

Updated

11 years ago
Duplicate of this bug: 374348

Comment 10

11 years ago
This should block 1.5 because the two most likely options:

1. Allow uninstall to delete the SeaMonkey folder, or
2. Delete files before allowing install/selecting a different install directory

Will lose all user-installed plugins and non-profile extensions. It would take an expert user to identify this and copy the files out before upgrading.
Requesting blocking flag.
Flags: blocking-seamonkey1.5a?

Updated

11 years ago
Blocks: 379157

Comment 11

11 years ago
blocking- just because we'll be using a different installer and uninstaller for the next major SeaMonkey release anyways.
Please re-evaluate once we have the new toolkit-based SeaMonkey as default on trunk and have landed the new NSIS-based installer code. I don't know how uninstall works with that. See bug 351917 for the ongoing work on this new installer.
Depends on: 351917
Flags: blocking-seamonkey1.5a? → blocking-seamonkey1.5a-
(Reporter)

Comment 12

11 years ago
WFM with SeaMonkey/2007052914-trunk/WinXP

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/2007052914 SeaMonkey/2.0a1pre
R.Fixed, by new NSIS installer, per previous "WFM" comment.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/2007053102 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

V.Fixed.

*****

(In reply to comment #8)
> the Start menu entries are not removed.

Test again, with the new installer,
then file a new separate bug if it is still happening.
Status: RESOLVED → VERIFIED
I just tested May 31st installer:
It has never been so buggy, I just wonder if won't leave Mozilla Seamonkey after 6 years , using this Mozilla Suite.

Regarding this bug: uninstalling just fails to start with an error, while the install log file looks fine.

Installation actually fails to import my multiple profiles (only a single one is allowed), fails by trying to copy my 6 GBytes of mail messages from D drive to C drive where disk space is lacking (fails silently, why does it want to *copy* these messages ?) : I ended with a full drive and 90% of my mails are missing

Give me back the previous installer !

Comment 16

11 years ago
I didn't have a problem with it not removing the directory, but the thing I had to do by hand was to go back and remove all the entries from the Windows registry using regedit. I do this maybe every 2 weeks to clean out old entries, including old talkback stuff. I haven't checked regedit since the new one is out, but will check back here after I do.
You need to log in before you can comment on or make changes to this bug.