Absolutely positioned pseudo-elements are treated as inline.

RESOLVED DUPLICATE of bug 238072

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 238072
12 years ago
12 years ago

People

(Reporter: Rafal Milecki, Assigned: dbaron)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Opera/9.00 (X11; Linux i686; U; en)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050702

Acording to http://www.w3.org/TR/REC-CSS2/visuren.html#q24 absolutely positioned element should be displayed as block. Mozilla ignores width of pseudo-element with { position: absolute; }.

Reproducible: Always

Steps to Reproduce:

Actual Results:  
Pseudo-element has width of contained text.

Expected Results:  
Pseudo-element should has width set in CSS (300px on page from URL).
Created attachment 216956 [details]
testcase from reporter's URL

Updated

12 years ago
Keywords: testcase

Comment 2

12 years ago
BTW: Your Mozilla build is quite old, consider upgrading to SeaMonkey 1.0 or something similar.
Assignee: nobody → dbaron
Component: Layout → Style System (CSS)
QA Contact: layout → ian

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 238072 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.