Closed Bug 332505 Opened 14 years ago Closed 14 years ago

"Firefox already running" status can get locked, permanently blocks Fx running, even after reinstall + reboot

Categories

(Toolkit :: Startup and Profile System, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 278860

People

(Reporter: contactbox, Unassigned)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: 1.5.0.1 (Windows)

I've just reinstalled firefox 1.5.0.1, and reinstalled cleanly. All went well until it finished installing and tried to run.

"Firefox is already running but not responding, close existing process or restart."

There was no existing process (confirmed in Task manager and System Process Explorer), but it persisted, safe mode wouldn't let it run either. So I rebooted and... it's still convinced firefox is running. I've uninstalled and reinstalled, rebooted, tried safe mode, and it still completes install properly then reports it's running on program startup and click OK to close.

1. Theres a bug needs fixing
2. Can anyone tell me how to clear whatever setting it's looking at manually, since I'm having to file this bug using IE instead.

Reproducible: Always

Steps to Reproduce:
Steps to reproduce untested.

It's enough that the test used in Fx for "is program already running" is capable of obtaining the wrong answer in a manner even reinstall and reboot doesn't clear.



How I got here is messy, but can be explained. Perhaps some of the following could have been done better but this issue will still need addressing. 

I'm filing it as critical - due to seriousness of "software hangs and can't be unhung or fixed by reinstall", because although I hit this bug by deleting the program folder, perhaps others will hit this bug in some other way, and will also have Fx hang and refuse to run as well. Anyway, here's what I did, as best I can tell:

I had clean installed fx, and set about trialling a bunch opf extensions. I installed about 50 (including alternative extensions for many functions such as tabbed browsing, to compare), restarted Firefox, and disabled all but 10 that looked most useful, then went about browsing, mostly with very happy results.

I then came across http://www.mozilla.org/support/firefox/profile#move which solved a big problem I had and let me move the profile folder. Which I did, and edited profile.ini accordingly, and all went well.

Fx was actually pretty good. It was about 95% but not 100% happy I'd say, see bug report https://bugzilla.mozilla.org/show_bug.cgi?id=332019 for an example of the issues I came across.

So after playing around a bit I decided to clean install, and use my experiuence to date, to set it up better, and work around the few issues which I was having.

Now, I admit, I should have uninstalled. But I didn't. I quit Firefox 100%, and deleted the program folder and profile folder instead, for which I slap my wrist. Then, program and profile deleted, I reinstalled the program.

The install worked fine, but after installing, Firefox simply refused to launch. It reported that it was already running and should be quit, and it's stuck there on that error message ever since. I've uninstalled, rebooted, checked task manager... done everything I can think of, nothing works. Firefox is persistently convinced it's running already. Apologies for the install snafu, hope the bug report helps and... can someone also suggest how to manually fix or diagnose it so I can get back to a decent browser? :)
Could very well be your firewall that prevents Firefox from starting up
Thanks - profile manager solved it for me -- I'm back in Firefoxland now :)

I've changed the allocation to major, however, because any issue that means a program can be blocked from launching and persists past reinstall and reboot, and whose solution is on an obscure page of the mozilla wiki that you have to know exists to find out about, is not a "normal" level of issue. 

At the very least the error message needs updating to explain that profile issues can cause this error, see LINK, so users who get it can solve it, and also the profile manager shortcut should be added to the Fx start menu since its a function many people will find useful.
Severity: normal → major
Okay, I have a diagnosis and a fix for this bug.

The problem comes down to this:

If the profile folder cannot be found on program startup, the user gets the "firefox is already running" message. Since profiles.ini persists through reboot and reinstall, and profile folder is only ever created by the installer in the default location and not in the location pointed to by profiles.ini, the problem persists during reboot and reinstall.

Steps to reproduce: Quit firefox. Rename profile folder (as linked from profiles.ini) to some other name (eg "profile.temp") and try to run firefox. Program will not start up. Error message "Firefox is already running". Rename the profile folder back to same name as in profiles.ini, and it works again.

Analysis: When firefox reinstalled, the installer did NOT recreate profiles.ini. Instead, it seems it had noted there was an existing profiles.ini and left it as it was. Since I'd deleted the old profile in anticipation of reinstall, hence on program startup it couldn't find the profiles folder and failed to start as above. The flaw is in the installer, it EITHER does not rewrite profiles.ini to point to the profiles folder, OR does not check the profile folder actually exists and is valid.

Further observation #2: What would happen if the folder pointed to existed from an old install, or existed but contained certain corrupt data? Would the user be stuck with a mysteriously failing firefox that no matter how often they reinstalled failed to run correctly? Should the installer ask for a profile folder location, or check if it already exists whether to create a new (empty) one?
Sorry, the error is primarily in the installer, but should also be caught on program launch, I mean.

*** This bug has been marked as a duplicate of 278860 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Component: General → Startup and Profile System
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.