ads within the page fail to load due the Redirection limit for this URL exceeded.

VERIFIED INVALID

Status

VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: xhu, Assigned: mikepinkerton)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0

The content of this page will load without problem, while all ads areas fail to display properly due to Redirection limit for this URL exceeded.

Reproducible: Always
i'm perplexed why this doesn't happen in firefox too. does it only happen with adblocking turned on? 
(Reporter)

Comment 2

13 years ago
No. Currently, I have adblocking turned off and still the problem exists.
That error message is caused by sites which misbehave when you block them from setting cookies.

The first time through, I got the error, and while watching what cookies I was asked to accept (so I could later delete them) and searching my exceptions list, I noticed bbs.ibox.com.cn was already blocked.  Unblocking it and reloading the page caused me to get asked about all of the allyes.com servers, and the ads loaded when I accepted all the allyes cookies (or, didn't load with ad-blocking on, but no longer produced the error frames).

Deleting the cookies and setting the allyes.com sites back to deny caused the error frames again (and blocking those sites in Fx causes the exact same issues).

This is INVALID...not because you're blocking cookies per se, but because the site is misconfigured to go into an infinite redirect loop when it can't set cookies, and Gecko throws the error message to stop the infinite redirect loop.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.