Assert on shutdown with safe-browsing extension: "Event listener manager hash not empty at shutdown!"

RESOLVED INVALID

Status

()

Toolkit
Safe Browsing
--
major
RESOLVED INVALID
12 years ago
4 years ago

People

(Reporter: bz, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

BUILD: Current trunk build

STEPS TO REPRODUCE:

1) Build the safe-browsing extension (eg --enable-extensions=all)
2) Start the browser.
3) Quit.

EXPECTED RESULTS:  Clean shutdown.

ACTUAL RESULTS:

###!!! ASSERTION: Event listener manager hash not empty at shutdown!:
'sEventListenerManagersHash.entryCount == 0', file
../../../../mozilla/content/base/src/nsContentUtils.cpp, line 642

We're not leaking (at least through shutdown) that I can see, but could we still be holding refs to DOM nodes at the point when shutdown gets here or something?

Updated

12 years ago
Summary: Assert on shutdown with safe-browsing extension → Assert on shutdown with safe-browsing extension: "Event listener manager hash not empty at shutdown!"

*** This bug has been marked as a duplicate of 334524 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
This bug is more specific.
Blocks: 334524
Status: RESOLVED → REOPENED
Flags: blocking1.9a2?
Keywords: regression
Resolution: DUPLICATE → ---

Comment 3

12 years ago
I'm not seeing this anymore in a Linux debug build from 20060908. I have no idea when this was fixed, however.

Comment 4

12 years ago
This is probably still true of the extension, but I was pretty sure I got rid of this assertion when migrating into /browser.

I'll just put a dependency on bug 337336 (remove the code in /extensions/safebrowsing/) for now.
Depends on: 337336
Flags: blocking1.9a2? → blocking-firefox3?

Comment 5

12 years ago
I removed the extension from CVS (bug 337336) so this should no longer be an issus.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID

Updated

12 years ago
Flags: blocking-firefox3?
(Assignee)

Updated

4 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.