New mail of SeaMonkey can not handle cut and past of email from Outlook Express

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Wiilliam Ed Taylor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060403 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060403 SeaMonkey/1.5a

The data copied from an Outlook express email canot translate the HTML code when pasted into the new SeaMonkey email.

Reproducible: Always

Steps to Reproduce:
1.Open an email from Outlook Express.
2.Open a create New email from SeaMonkey.
3.Copy some or all of the email content froom Outlook Express (Select, Cntrl-C)
4.Paste (Cntrl-V) into the newly open blank email for SeaMonket.

As of the nightly as of 04/03 I just downloaded. It will not paste anything. Unless I past as quoted text or past without formatting. Which is wired, because when creating a responce message to a newsgroup thread. 90% of the time it will only let me paste as quote. This is no good. So I have waste time taking the quote symbol out so the message does not get confused to the text being replied to.

Actual Results:  
The last two cases possibly illustrate a bug, in that the sequence expression
is obviously (and perhaps inadvertently) pushed down to the interator used to
discover the count result, whereas, without refering to the SQL standard, I
think its quite probable that the 'next value for' expression is supposed to
be applied 'last' to the single row result obtained from the output of the count
aggregate.

Also, there are a number of places that HSQLDB freely allows the use of 'next
value for', despite our being aware that those places are explicitly disallowed
by the SQL standard.

As for the first case, it is correct because the table has no rows at that point.
You'll get the same thing selection 1 or "a string" or anything else from a
table with no rows.  Indeed, I think that's part of why Oracle provides the
DUAL table (create table dual(dummy varchar2); insert into dual values(null);
grant select on dual to public).

OTOH, selecting count from an empty table obviously must generate a result...how
else to represent a count of zero?  In  general, the same applies to all aggregate
queries, where each virtual table (each subset representing an aggregate group)
generates a row in the output result.

Comment 1

10 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008020803 SeaMonkey/2.0a1pre
data copied from outlook on XP (I don't have outlook express)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.