Closed Bug 332669 Opened 15 years ago Closed 15 years ago

Add "overflow:auto" to an invisible parent tag, and the scrollbar is always visible

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 187435

People

(Reporter: minfrin, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

- create a DIV designed to become visible on error (in our case), ie "visibility:hidden".

- add "overflow:auto" to one of the children of the DIV, and make sure this child is big enough to need to scroll.

- Even though the parent is invisible, and the element containing the scrollbar is invisible, the scrollbar itself is always visible, and hovers eerily above the page.

The HTML looks somewhat like this:

<DIV id="dialogWindow" style="position: absolute; visibility:hidden;z-index:201;height:200px; width:300px; left:20px;top:100px;background-color: #ffffff;border-width:1px;border-style: solid; border-width: 1px;border-color: black;"> 

	<table id="dialogWindowHead" width=100% style="background-color: #e5001d;height: 20px;" onmousedown="dragStart(event, 'dialogWindow')" class="dialogHeader">
		<tr ><td align="center" id="dialogWindowHeadMessage" >
			Error
		</td></tr>
	</table>
	<ul id="dialogList" style="height:149px; overflow:auto;" class="dialogList">

<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
<li>lots and lots of content</li>
	</ul>
	<table width=100% style="height:30px;" class="dialogButtons">
	<tr id="dialogButtons"></tr>
	</table>


</DIV>


Reproducible: Always

Steps to Reproduce:
This looks like bug 187435. Please reopen if you don't agree.

*** This bug has been marked as a duplicate of 187435 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.