character encoding menu is confusing

RESOLVED DUPLICATE of bug 185123

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 185123
12 years ago
12 years ago

People

(Reporter: martin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

In the menu "View :: Character Encoding" I would expect to choose:

    EITHER Auto-detect OR a specific encoding

further I would expect FF to have a checkbox ticked next to ONE SINGLE ITEM which would be the one setting that is currently in use.

Today neither or these expectations are fulfilled. Questions:

1. Why is there alternatives like "Japanese", "Korean" and so on under the auto-detect sub-menu? Maybe this is obvious to hardcore mozilla techies but for the typical end-user is just makes no sense.

2. Suppose I have checked "View :: Char enc :: Unicode" and then selects "View :: Char enc :: Auto-detect :: Universal". Now suddenly both of these are checked, what does that mean? 

This menu is by no means intuitive.


Reproducible: Always

*** This bug has been marked as a duplicate of 185123 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.