Java Lang error message hangs Camino, cannot close window or use browser.

VERIFIED INVALID

Status

Camino Graveyard
Plug-ins
--
critical
VERIFIED INVALID
12 years ago
12 years ago

People

(Reporter: Jeffrey, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0

Happening at least once or twice a week on various sites.  No identifiable
pattern by me so far.  --very irritating!

This error message hangs Camino, cannot close window or use browser.

error - Java: java.lang.UnsatisfiedLinkError: getProxyConfigURL

(cannot enter any page or record any key bookmarks in research.)
Had to take Camino off default browser until this is resolved.



Reproducible: Didn't try

Steps to Reproduce:
1.Have not tried to repoduce, too irritating and time consuming
2.
3.

Actual Results:  
(eror message just appears suddenly without warning at random, requiring force quit.)


I have various screenshots available.

--

about:buildconfig

Build platform
target
powerpc-apple-darwin8.4.0

Build tools
Compiler 	Version 	Compiler flags
gcc-3.3 -arch ppc 	gcc version 3.3 20030304 (Apple Computer, Inc. build 1819) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -nostdinc -isystem /Developer/SDKs/MacOSX10.2.8.sdk/usr/include/gcc/darwin/3.3 -isystem /Developer/SDKs/MacOSX10.2.8.sdk/usr/include -F/Developer/SDKs/MacOSX10.2.8.sdk/System/Library/Frameworks -F/Developer/SDKs/MacOSX10.2.8.sdk/Library/Frameworks -fpascal-strings -no-cpp-precomp -fno-common -I/Developer/SDKs/MacOSX10.2.8.sdk/Developer/Headers/FlatCarbon
g++-3.3 -arch ppc 	gcc version 3.3 20030304 (Apple Computer, Inc. build 1819) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -nostdinc -nostdinc++ -I/Developer/SDKs/MacOSX10.2.8.sdk/usr/include/gcc/darwin/3.3/c++ -I/Developer/SDKs/MacOSX10.2.8.sdk/usr/include/gcc/darwin/3.3/c++/ppc-darwin -I/Developer/SDKs/MacOSX10.2.8.sdk/usr/include/gcc/darwin/3.3/c++/backward -isystem /Developer/SDKs/MacOSX10.2.8.sdk/usr/include/gcc/darwin/3.3 -isystem /Developer/SDKs/MacOSX10.2.8.sdk/usr/include -F/Developer/SDKs/MacOSX10.2.8.sdk/System/Library/Frameworks -F/Developer/SDKs/MacOSX10.2.8.sdk/Library/Frameworks -fpascal-strings -no-cpp-precomp -fno-common -fshort-wchar -I/Developer/SDKs/MacOSX10.2.8.sdk/Developer/Headers/FlatCarbon -I/usr/X11R6/include

Configure arguments
--enable-application=macbrowser --enable-default-toolkit=cocoa --disable-tests --disable-accessibility --disable-jsd --enable-single-profile --enable-canvas --enable-svg --with-macos-sdk=/Developer/SDKs/MacOSX10.2.8.sdk --target=powerpc-apple-darwin8.4.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.2.8.sdk '--enable-optimize=-O2 -g' --disable-shared --enable-static
about:buildconfig

Build platform
target
i686-apple-darwin8.4.0

Build tools
Compiler 	Version 	Compiler flags
gcc-4.0 -arch i386 	gcc version 4.0.1 (Apple Computer, Inc. build 5250) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fpascal-strings -no-cpp-precomp -fno-common -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon
g++-4.0 -arch i386 	gcc version 4.0.1 (Apple Computer, Inc. build 5250) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fpascal-strings -no-cpp-precomp -fno-common -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon

Configure arguments
--enable-application=macbrowser --enable-default-toolkit=cocoa --disable-tests --disable-accessibility --disable-jsd --enable-single-profile --enable-canvas --enable-svg --with-macos-sdk=/Developer/SDKs/MacOSX10.2.8.sdk --target=i686-apple-darwin8.4.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.4u.sdk '--enable-optimize=-O2 -g' --disable-shared --enable-static
(Reporter)

Comment 1

12 years ago
Created attachment 217160 [details]
error message screen shot, including URL noted in original entry

I have several more screen shots saved from other URLz where it happened.
On the trunk (10.3.9), I just get a message in the status bar that the applet failed to load, so it's possible this is an issue that's been resolved in the latest JEP.

In 1.0, Camino simply crashes for me (well, Java crashes, and that crashes Camino)...no error dialogue shown, and no "hanging" or locked state, which sounds like what this really is.

Note that copy/pasting about:buildconfig into the comments is completely unhelpful, but providing your Mac OS X version and the full URL on which the problem occurred would have been useful ;)
Component: General → Plug-ins
QA Contact: general → plugins
I still crash when I try to use the latest JEP (0.9.5+d) with Camino 1.0, but I don't crash with a 1.8branch build (got the same error as the trunk), so it's possible that something other than the JEP is really triggering the crash.  

If you want to try with the latest JEP, see the steps in bug 325987 comment 16.

But, what I'd like you to try is the lastest 1.8branch build (which has 0.9.5+d already, but which has a subset of other fixes from the trunk) and see if that's any better behaved for you (since I never saw the dialogue you did)....
I don't see a crash with this URL.

But I do get a Java error (basically the same error) with Camino 1.0
(plus JEP 0.9.5+d) on OS X 10.4.5 (with J2SE 5.0), Mozilla 1.7.12 on
Windows XP (with J2SE 5.0) and Mozilla 1.7.12 on SuSE Linux (with Java
1.4.2).  Clearly there's something wrong with the applet.  And I
suspect this problem also caused the reporter's Java error from
comment #0.

Smokey, I suspect that your crash(es) are unrelated, and are
(probably) seldom encountered.  But I have no idea what their cause
might be.  It'd help if you attached some crashreporterd logs.

The error I saw with J2SE 5.0 on both Mac OS X and Windows was
"java.lang.class.FormatError: Incompatible magic value 218774632 in
class file vmd/player/nushu/MiNXPlayer".  With Java 1.4.2 (on SuSE
Linux) it was "java.lang.ClassFormatError: vmd/player/nushu/MiNXPlayer
(Bad magic number)"

Created attachment 217246 [details]
JavaNativeCrash.log and crash log

Steven, here's the oh-so-descriptive crash log from the crash I saw with Camino 1.0.  When you looked at this, did it ever hang or get in a locked state for you, or did you just see the dialogue and dismiss it?

Given that this is one of those "bad magic number" applets and it doesn't seem to crash/hang/lock up on the 1.8 branch or the trunk, I'm not sure there's much we can do ;)
I've figured out what this particular "incompatible magic value"
(218774632) means, and what the server is doing to cause the error.

This number translates to 0x0D0A3C68 in hexadecimal, which in turn
translates to "CR LF < h" in the 7-bit ASCII/ANSI character set

The following is the URL for the applet's jar file (obtained by doing
"View Source" and then combining the applet's "codebase" with its
"archive"):

http://www.vmdirect.com/dvmuser/DVMPlayer/DVMneoPlayer1.jar

When you try to download this jar file directly, you get an error page
telling you that "this VMdirect Site ID is invalid".

When you do "View Source" on that page, the first line is blank and
the next two lines are:

<html>
<head>

The first four bytes of that are ... you guessed it :-)

The original report is INVALID.

I'll take a look at your crash log, though, Smokey.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Smokey, your log contains our old friend
Java_MyCAppletFrame_getViewPtr.  And I notice that you were running
JEP 0.9.5+c when the crash happened.  Try exactly the same
configuration you crashed with, except change to JEP 0.9.5+d.

https://bugzilla.mozilla.org/show_bug.cgi?id=330956#c11
Created attachment 217253 [details]
Crash log from Camino 1.0 + JEP 0.9.5+d

(In reply to comment #8)
> Smokey, your log contains our old friend
> Java_MyCAppletFrame_getViewPtr.  And I notice that you were running
> JEP 0.9.5+c when the crash happened.  Try exactly the same
> configuration you crashed with, except change to JEP 0.9.5+d.

I tried that this afternoon and crashed just the same, and the tops of the crashing stacks were the same, so I stopped reading after 10 or so lines ;)  Indeed, the Camino 1.0/JEP 0.9.5+d stack doesn't have our old friend.
Smokey, your crashes have me stumped:  I can't reproduce them, and
can't guess why they're happening.  I suspect that we'll simply have
to put them aside for future reference.

The two logs aren't identical, though they're quite similar.  In both
cases the crash happens as an applet is being loaded, in low-level
display code (in JNI code, though (in this case) the calls aren't
being made from Java code).  So it's odd that the crashes happen on
this particular URL, which never loads an applet.

Also (crucially), both crashes happen in JNI code that's attempting to
"look up" a Java class (and to load it if it's never been "looked up"
before).  This suggests that the JVM hasn't been properly initialized.

So we need to round up the usual suspects:  Are you using any
extensions or other plugins, and what happens if you don't use them?

But I'd also like to know if it makes any difference if you first load
some other applet (thereby properly initializing the JVM), and then
visit this bug's URL.

(Reporter)

Comment 11

12 years ago
Created attachment 217409 [details]
additional URL ScreenShot

You may find the crash duplicable at this location.
Thanks for you dedication
If I load http://gemal.dk/browserspy/java.html and then load the URL from this bug, I now (Camino 1.0 with 0.9.5+d) get the same behavior I get with the 1.8branch and trunk builds--no crash, the page loads, the applet doesn't work.

--

I don't get any error--or any crash, even if I haven't initialized the JVM first--on the URL from comment 11 (http://thesecret.tv/movie/trailer.html); the movie just plays after I accept the applet's security certificate.
> If I load http://gemal.dk/browserspy/java.html and then load the URL
> from this bug, I now (Camino 1.0 with 0.9.5+d) get the same behavior I
> get with the 1.8branch and trunk builds--no crash, the page loads, the
> applet doesn't work.

Interesting.

Here's another question (one I forgot to ask last night):  Have you
added any "runtime parameters" in the Java Control Panel?

Jeffrey, you still haven't told us what version of Mac OS X you're
using.
(Reporter)

Comment 15

12 years ago
Sorry: Mac OS version 10.3.9
> Mac OS version 10.3.9

Thanks.

Here's another question:  Enter "about:plugins" in Camino's "location
bar".  Scroll down the list of plugins until you find "Java Embedding
Plugin".  A version number should be listed after the name.  What is
it?

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.