Closed Bug 332722 Opened 14 years ago Closed 10 years ago

JS Test Library date failures on night of switch from Standard to Daylight savings time

Categories

(Core :: JavaScript Engine, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
status1.9.2 --- beta5-fixed

People

(Reporter: bc, Assigned: bc)

References

Details

(Keywords: intermittent-failure, Whiteboard: [orange:time-bomb])

Attachments

(1 file)

My test run on 2006-04-01 showed a number of date related errors which I do not believe are normal. My assumption is these errors are caused by a) bugs in the tests or b) bugs in the js engine for date/times close to the transition time.

I am attaching a summary of the failures for later inspection. If someone wants to help figure this out, that would be great otherwise I will get to it when I have a Round Tuit(tm).
I am unable to reproduce (so far) the other crashes in ecma_3/Date/15.9.5.5.js and ecma_3/Date/15.9.5.6.js on windows...
Depends on: 309392, 333366
Filed bug 334427 on the ecma_3/Date/15.9.5.5.js and ecma_3/Date/15.9.5.6.js windows only jsDriver.pl crashes.
Depends on: 334427
This test appears to have problems around midnight...

test: ecma/Date/15.9.5.12-1.js result: FAILED type: shell   : papayassh/2006-04-20-00-24-00-firefox-2.0-dbg-mac-1.8_2006041901.log : description:  

 Failure messages were: 
(new Date(1174116403709)).getDay() = 6 FAILED! expected: 5 
(new Date(1205911603709)).getDay() = 3 FAILED! expected: 2 
(new Date(1225178803709)).getDay() = 2 FAILED! expected: 1 
(new Date(1236670003709)).getDay() = 2 FAILED! expected: 1 
re-enable ecma_3/Date/15.9.5.5.js which only fails on linux during dst.
http://hg.mozilla.org/tracemonkey/rev/184430c346f4
http://hg.mozilla.org/mozilla-central/rev/184430c346f4
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
These bugs landed after b4 was cut. Moving flag out.
Whiteboard: [orange][orange:time-bomb]
Blocks: 438871
Whiteboard: [orange][orange:time-bomb] → [orange:time-bomb]
You need to log in before you can comment on or make changes to this bug.