Closed Bug 33275 Opened 20 years ago Closed 20 years ago

Two HTTP status lines -> Can't log in to Ebay

Categories

(Core :: Networking, defect, P3, major)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: pollmann, Assigned: gagan)

References

()

Details

(Whiteboard: [nsbeta2+])

I came up with a fix for my part of bug 18728 (can't log into Ebay), which was 
that we were submitting form variables out of order.

But to add insult to injury, not ONLY does their login CGI not accept variables 
out of order, but when they are in the correct order, it responds with this:

-------------------------------------------------
HTTP/1.0 200 OK
Server: Microsoft-IIS/4.0
Date: Sat, 25 Mar 2000 00:35:44 GMT
Set-Cookie: s=AQAAAAIAAAABAAAANAAAAOAJ3DhAE9w4MXBvbGxtYW5uICQxJE1vemlsbGEvJDYuV
HTTP/1.0 200 OK
Server: Microsoft-IIS/4.0
Date: Sat, 25 Mar 2000 00:35:44 GMT
-------------------------------------------------

And we respond with a document load error, and display nothing.

The two HTTP status lines are my best guess for why we aren't displaying the 
page returned after a successful login.  I'll try to get bug 18728 checked in 
today, so this bug will be unblocked.
Depends on: 18728
No longer depends on: 18728
The fix for bug 18728 has been checked in.
You'll need an eBay account to log in.  Updating URL to point at the log in 
page, though you can get there by clicking "Log In" anywhere on eBay.com
*** Bug 33379 has been marked as a duplicate of this bug. ***
Why did I get this bug?
Reading through this more closely, I see that it was gated by fixing the 
out-of-order problem. But what else is wrong here?

=> pollmann
Assignee: warren → pollmann
Warren, as noted above (2000-03-24 21:21) I fixed the out-of-order bug on 
Friday.  Handing this back to you.  It appears that the HTTP headers that the 
server returns are screwing us up, see them pasted above.

I save the page returned locally (or from any of my web servers) and it loads 
fine, but when I load it from Ebay servers, which submit the duplicate headers, 
the page doesn't load.
Assignee: pollmann → warren
Ok, Gagan should look at this. Thanks.
Assignee: warren → gagan
Target Milestone: --- → M16
In NEtscape nb1b from netscape, build 200003312 I just logged on to one of the 
message board  I was able to log on ok. 
Moving to M17 which is now considered part of beta2.
Target Milestone: M16 → M17
I have a fix... and EBay's been notified as well... 
Status: NEW → ASSIGNED
Whiteboard: 1d
Has any progress been made on this?  I'd love to use Mozilla for browsing eBay,
since it "feels" so much faster and I think the formatting is easier to read.
Unfortunately there's very little I can do with the site, since most of eBay's
servers respond with the doubled headers.
This seems to be fixed in Linux build 2000053020.  I can make use of all parts
of the eBay site and I've verified that they're still sending out the doubled
headers.
*** Bug 42368 has been marked as a duplicate of this bug. ***
marking as nsbeta2+ per the dup. 
Keywords: nsbeta2
Whiteboard: 1d → nsbeta2+
More from Bug 42368: Doubled redirect headers are causing us to append the two 
path's together which is slightly different that what I originally saw in this 
bug (doubled OK headers)
Whiteboard: nsbeta2+ → [nsbeta2+]
Marking Fixed per gagan
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
verified:
Win NT 2000071308
Status: RESOLVED → VERIFIED
Hmm... the fix for this has just been checked in (somehow it had slipped the
last time around. Marking this closed again for reverification (this time with
the fix :))
Status: VERIFIED → CLOSED
reopening and closing to get verified again. 
Status: CLOSED → REOPENED
Resolution: FIXED → ---
fixed again. pls. verify.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
I can still log on to ebay.
verified:
WinNT 2000072811
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.