Closed Bug 332821 Opened 15 years ago Closed 15 years ago

DOM siblings give undefined

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 26179

People

(Reporter: korneelwever, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

When getting the siblings from the DOM, FireFox gets more than there are. 
click Sort on my URL and the alerts should give the innerhtml of each sibling (and their previous) of 'body'.

Instead it gives 'undefined's' and innerhtml.

Tested in IE and FireFox and Mozilla. IE works fine :'(

Reproducible: Always

Steps to Reproduce:
1.Click sort on URL
2.See Page Source
3.

Actual Results:  
an alert with 'undefined > b text' 

Expected Results:  
an alert with 'a text > b tekst'

It seems FF is getting tags '<div' as siblings, which is to be correct. But the </ should not, looks like they also are taken.
IE has a known HTML parser bug that causes it to sometimes, but not always, lose text nodes from the DOM.  See bug 26179 for details.

*** This bug has been marked as a duplicate of 26179 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.