Passwords encoded differently on front-end and developers end

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
12 years ago
2 years ago

People

(Reporter: James Ross, Assigned: morgamic)

Tracking

Details

(Reporter)

Description

12 years ago
The "Log In" link and the login page from trying to make a comment/rate one fails to accept my login information, even though the exact same information (I checked twice) works on the Developers part. To make it worse, it wont do the Create Account thing because my e-mail addresss is in use!

This is kind of a regression, being unable to log in, but since I can still log in to the Developers bit I'll spare this bug the keyword.
(Reporter)

Comment 1

12 years ago
Ok, this is quite bad. I reset my password for the front end, and that worked, but not I can't log in to the Developers area. I'm betting that after resetting that one I'll not be able to log in to the front end again...
(Reporter)

Comment 2

12 years ago
I think I know the problem: it's an encoding issue.

If I use a simple password, it works fine, but if I use (say) £ (UK pound sign) it will only ever work in one system. This is almost certainly because one is encoding it in ISO and the other UTF-8.
(Reporter)

Updated

12 years ago
Summary: Unable to log in to make comment/rate comments → Passwords encoded differently on front-end and developers end

Comment 3

12 years ago
We should be using UTF everywhere.
Target Milestone: 1.0 → 2.1

Comment 4

12 years ago
Would this also lead towards the login info being remembered differently?
(Reporter)

Comment 5

12 years ago
That is the bug, I think. The two forms are taking input as different encodings. I've already had to help one person work around the DevCP not /actually/ being UTF-8.

As far as I can tell, the DevCP side of things is taking the incoming bytes as ISO-8859-*, when in fact the browser is using UTF-8 (because the page is in UTF-8). All it needs is for the new password reset page to /actually/ be working in UTF-8 and you'll end up with different stored data depending which form you use (and thus only able to log in to half the site, as I was until I used a simple password).

Comment 6

12 years ago
Organising bugs. Sorry for the bugspam.
Version: unspecified → 2.0
Target Milestone: 2.1 → ---

Comment 7

11 years ago
Now there is only one login page; closing.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.