Closed Bug 332843 Opened 14 years ago Closed 14 years ago

Make old urls redirect to v2 urls.

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect, critical)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cameron, Assigned: ecfbugzilla)

References

Details

Attachments

(1 file)

We ought to make old urls redirect to new ones. It doesn't have to be perfect, but yeah. Anyone with extensions that point at pages, links on their sites and bookmarks will appreciate it.

https://addons.mozilla.org/extensions/moreinfo.php?id=398&application=firefox currently points at/is the same as https://addons.mozilla.org/firefox/398/ but if there's anything else in the url, it messes it. 

eg:
https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&id=398&&page=comments
https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&id=398&page=releases
https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&id=398&page=staffreview
https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&id=398&page=opinion
https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&id=398&page=previews
https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&id=398&vid=123456789
https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&category=Popular&numpg=10&id=398

Etc. etc. etc.

Basically, I don't think it's particularly important to make them all link to their new locations, although it could be kinda nifty, but it's easier to just make anything with application=firefox and &id=123 (note the &, otherwise it will pick up vid aswell) in the url point at https://addons.mozilla.org/firefox/123/

Anything with application=mozilla in the url can point at https://addons.mozilla.org/mozilla/123/ and likewise for thunderbird.

Additionally, we ought to make author profiles work in the same way. https://addons.mozilla.org/extensions/authorprofiles.php?id=473 should point at https://addons.mozilla.org/foo/473/author/
I'm currently not quite sure about the author profile links and what we should replace foo with, but ah well, you get the idea.
*** Bug 333567 has been marked as a duplicate of this bug. ***
Organising bugs. Sorry for the bugspam.
Version: unspecified → 2.0
Severity: major → critical
Status: NEW → ASSIGNED
Target Milestone: Future → 2.1
I don't think anybody cares about comment links and the such. But links like https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&id=1865 or even https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&category=Newest&numpg=5&id=1865 are very common and currently they don't work. Check out Firefox Facts ebook (http://www.firefoxfacts.com/ebook/FirefoxFacts.zip) for example, lots of unusable links there. I think that's a top priority.
Attached patch Proposed patchSplinter Review
Adjusting rewrite rules in htaccess.dist. Changes:

1. Made the redirects from /extensions/ and /themes/ 301 Moved Permanently - this is very important for search engines and simply good style.
2. Made several typical old-style links redirect to the current /firefox/123/ - the user should see the correct link.
Attachment #221225 - Flags: first-review?(morgamic)
Comment on attachment 221225 [details] [diff] [review]
Proposed patch

Looks good, except the hard-coded rewritebase for the new rewrites.  Stripping those out and checking this in.
Attachment #221225 - Flags: first-review?(morgamic) → first-review+
Committed -- will push up to sysadmins for insertion into .conf.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
I'm not quite sure about resolving this bug just yet. Eg - old rss urls, old author profile urls - do we think these are important?

Additionally, despite my specifically noting the similarity between id and vid, you bugled it up anyway trev :D See bug 338609 ;)
Well, whoever was subscribed to RSS, probably noticed that the links stopped working a while ago. And I don't think there are external links to these. Author profile links might be worth fixing on the other hand.
If we need access to web server logs to see what URLs are actually being hit, we should get them.  Guessing about what pages are in use is a bad plan, and leads to pain.

It might be OK to break some pages, but we should do it very explicitly, and if there's somewhere else we can point them at that's equivalent then we should do that.
Target Milestone: 2.1 → ---
Assignee: morgamic → trev
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.