Closed Bug 332870 Opened 14 years ago Closed 14 years ago

[RFE] Creating Calendar event by double-click should guess event time

Categories

(Calendar :: Sunbird Only, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 321535

People

(Reporter: Aleks.Ehrlich, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

When you add a calendar event in, say, Day View, by double-clicking the view, the date of the new event is derived properly from "the day you have double-clicked". It is not so for the event time, though; seems that the time for the new event is chosen by some logic like "use current system time" (for me it chooses "1 hour less than system time", i.e. 22:00-23:00 when created at 23:34; see also bug 332868 "Local calendar events displayed 1 hour earlier"), irregardless of where on the View do I double-click.
In the Week View, the date of the event created by double-click is guessed properly (corresponds to the double-clicked day).

Reproducible: Always

Steps to Reproduce:
1. Open Sunbird in the Day View
2. Double-click empty time between 13:00 and 14:00 (or any other empty time) in the Day View
3. A "New Event" window is displayed, observe its "From" and "To" time part

Actual Results:  
A "New Event" window is displayed, having "time from" set to 22:00 and "time to" set to 23:00, assuming your system time is 23:34; the times guessed for "New Event" do not depend on where you double-click.


Expected Results:  
The time from-to for a new event created by double-clicking in a view should be derived from "where the user double-clicks", i.e. if you double-click an area between 13:00 and 14:00 the new event shall start at 13:00 and end at 14:00 (assuming your default event length is set to 60 minutes).

Sunbird 0.3a1+ (build of April 04, 2006)
Basically the same idea as Bug 321535.  Marking as a duplicate.

*** This bug has been marked as a duplicate of 321535 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.